Updated version of Python plugin for IDEA 8 and 9

Today we’ve released an updated version of the Python plugin, with support for both IntelliJ IDEA 8 and “Maia” EAP. New features of the plugin include:

  • Graphical test runner
  • Python facet (allowing to work with Python scripts in Java and other modules)
  • Several new quickfixes
  • Code completion, syntax highlighting and editing improvements

You can find detailed release notes and screenshots of the new plugin on our Confluence space.

This entry was posted in News & Events and tagged . Bookmark the permalink.

8 Responses to Updated version of Python plugin for IDEA 8 and 9

  1. Ivo Busko says:

    Hi

    I am a IDEA user for a long time now, using it to manage our Java projects. Today I installed the Python plugin (on IDEA 8.1), and it seems to be performing as expected, except for one big thing: the editor seems to not recognize python syntax. The .py files themselves seem to be being recognized, as the project view show the tree of files as being valid Python source files. But as I bring a source file into the editor, no keywords or other language specifics highlight in the window. The text shows in plain black-and-white. Also, code completion and type ahead are not working at all. It is as if the editor thinks the .py file is just a plain text file, despite the fact the .py type is properly set in the file types list of recognized types.

    Do you know of any hidden setting that could be causing this behavior? I would hate to give up on IDEA as my Python IDE, since it is so good when working in Java, and I belive much of that hability is already in the plugin.

    Cheers,

    Ivo Busko
    Space Telecope Science Institute
    Baltimore, MD, USA

  2. Anand says:

    I have the same issue as described by Ivo Busko. But I Use Idea 9. Can some help please?

    Regards
    /Anand

  3. yole says:

    Anand,

    Please go to Settings | File Types and make sure that the .py extension is mapped to the Python file type, rather than plain text.

  4. sendi says:

    I have intellij 9.0.2 and I can’t compile my python program.
    it does not recognize, .pyd files it can not recognize datetime etc module although it recognized/hilited the .py file syntax.

    any help ? in anycase does any one have the “How to set up python in intellij ” ? document ?

  5. sendi says:

    It worked for me!

    Just install “ActiveState” Python
    install cx_oracle

    add python SDK in your intellij
    and it will work.

    although, it does not recognize all the imported packages and “Underlines” them saying unresolved package!, but if you run the program it works!

  6. katjonka says:

    can you tell me, please, how you add python sdk? In IDEA configuration in checkbox “use specified interpreter” only “” exist.

    screenshot is here http://gyazo.com/1f37a3c2a88d3d0c825973c2e8970f32.png

  7. katjonka says:

    can you tell me, please, how you add python sdk? In IDEA configuration in checkbox “use specified interpreter” only “project default” exist.

    screenshot is here http://gyazo.com/1f37a3c2a88d3d0c825973c2e8970f32.png

  8. katjonka says:

    sorry to trouble you, i find decision, and now it works!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">