IntelliJ IDEA 10 RC4; Android 2.3 support

A new week means that a new Release Candidate build of IntelliJ IDEA is in order. Among other changes, this build contains the final version of the licensing code. It means that you can use the build with your existing IntelliJ IDEA license if you’ve purchased one after November 1, 2010 and are entitled to a free upgrade to IntelliJ IDEA 10. Otherwise, you’ll need to select the 30-day evaluation option in order to use the build.

One more noticeable change is that the Android plugin now supports the Android 2.3 “Gingerbread” SDK, which was released yesterday.

Please give the new build a try – it’s probably the last chance to give us feedback on the new version before its final release.

This entry was posted in News & Events and tagged , . Bookmark the permalink.

12 Responses to IntelliJ IDEA 10 RC4; Android 2.3 support

  1. alexhe says:

    Wow, That’s fast.

    Thanks so much! ~Android developer

  2. hi, one more request about multiline messages in git log: they’re concatenated without any spaces and look ugly.

    thanks for the great work!

  3. tramsgar says:

    Your release process makes others’ claims of “agile” seem laughable… Great that you got this and other stuff fixed before release!

  4. I hope that after Idea X is kicked out of the door Pycharm builds will follow… the coupon expires on 31. Dec and I’m getting anxious :)

  5. Brian W says:

    Git pull should have a way to enable the –rebase flag

    Git merge is lightyears behind what tortoisegit does. Wish I could have tortoisegit do my merging etc. over intellij built in tool…

  6. yole says:

    Yury,
    Indeed, we plan to release a new EAP build of PyCharm later this week.

    Brian,
    Please file feature requests for improving the git integration into YouTrack at http://youtrack.jetbrains.net/

  7. Dennis Cairns says:

    There are two IDE settings that still do not work in RC4. I am using a MAC (Snow Leopard). I have reported this on youtrack. Please fix.

    1. Editor – Colors & Fonts – HTML – Tag: I cannot turn off the background color or change the background color of the HTML Tags. It always defaults to the gray.

    2. Editor – General – Console Background: this does not accept any user changes. The user selections will show in the dialog box, but the Console Background always remains white.

  8. paw says:

    hello

    today, after update android sdk my Logcat stop working :/ I have no idea whats happen. Logcat shows that there isn’t device selected – of course it’s not true.

    http://img695.imageshack.us/i/20101209044740.png/ – run config
    http://img196.imageshack.us/i/20101209044306.png/ – project and logcat view
    http://img819.imageshack.us/i/20101209045808.png/ – error

    do you know what could be a problem? I’ve Win 7 x64 and tried with java 64 and 32 and this isn’t solve problem.

    If you have any idea how to solve this problem I would be very grateful.

    cheers

  9. Eugene Kudelevsky says:

    paw, could you, please:
    1. reboot computer
    2. try to run sdk_folder/platform-tools/adb logcat
    3. try to use other tools (DDMS, Eclipse)

  10. paw says:

    thank Eugene for response.

    I tried your solution. I launch from command line adb logcat. After that I launch application in IJ. Log in command line was generated but also problem is that I can’t fired up application second time without closing emulator window.

    emulator: ERROR: the user data image is used by another emulator. aborting

    but when I started using android in IJ everything works perfect.

    Developing in eclipse works well but I’m used to use IJ (developing flex applications) so ith’s hard to change editor:)

    cheers

  11. Eugene Kudelevsky says:

    paw,
    I asked you to do that, because I cannot reproduce this problem, and we need to make sure that “adb logcat” and other tools works fine, so this is a problem of IDEA. Please, post this to the tracker and we’ll continue discussion there :) Thank you

  12. Marius Waldal says:

    +1 to Dennis Cairns’s problem.

    I am using version 10.0.3 on Mac OS X Snow Leopard, and I still can’t set the html tag background. Whatever I choose, it just resets to standard light gray.

    Same with Console Background.

    Marius

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>