IntelliJ IDEA 11.0.1

What could be a better way for the IntelliJ IDEA team to conclude the year 2011 than to release a bugfix update? And that’s exactly what we’re doing.

To upgrade to the new version, simply use the “Check for Update” action if you’re already running version 11, or grab the complete installer from the download page. And of course, the release notes for the new build are also available.

Happy New Year, and see you again in 2012!

This entry was posted in News & Events and tagged . Bookmark the permalink.

21 Responses to IntelliJ IDEA 11.0.1

  1. Nicolas says:

    And still no PHP plugin ??

  2. Jared says:

    Thanks for the update. Just in time for returning back to work after the holidays. :)

  3. yole says:

    The PHP plugin is available for installation through the plugin manager (Settings | Plugins). We don’t plan to put it back into the IntelliJ IDEA distribution.

  4. Vinny Carpenter says:

    When will be WebLogic Server 12c be supported? I am not able to connect to WebLogic 12c server to deploy an application. I’ll be creating an Youtrack issue soon.

  5. Nicolas says:

    Was not obvious that i have to “browse [plugin] repositories” to find out the php plugin. Thanks anyway.

  6. Victor says:

    “Check for Update” does not suggest the new version for me

  7. Victor says:

    It worked now.. Ignore my previous statement.

  8. Y says:

    Is there a way to install an update and not the full version again?
    I’m using the community version, and when checking for updates, it only states that a new version is available, but the options are only:
    1. A link to release notes
    2. Remind me later
    3. Ignore this update

    There’s no option to update.

  9. Mike says:

    Wish I could be happy about the release. It looks great, but 11.0.1 tends to keep chewing away at my CPU and then totally locks up when trying to look at module settings. Back to version 10.x.

  10. Dmitry says:

    Still no support of subversion 1.7 and Subversion 1.7 experimental integration plugin from repo is broken =(

  11. yole says:

    Y,
    The availability of the update option depends on the build which you’re upgrading from. See http://youtrack.jetbrains.net/issue/IDEA-79563 for more information.

    Mike,
    Please submit a CPU snapshot as described in http://devnet.jetbrains.net/docs/DOC-192

    Dmitry,
    As described in http://blogs.jetbrains.com/idea/2011/12/subversion-17-support-update/ the Subversion 1.7 support is planned for IDEA 11.1, not for a 11.0.x bugfix update. Also, what exactly do you mean by “broken”?

  12. Chris says:

    Hi,
    quick question, how is your update cycle time :-)
    I know, as a developer, I hat this question. Its done when its done…

    But I am struggling with the SVN 1.6 vs 1.7 issue (TortoiseSVN will either be 1.6 – then it cant update AnkhSVN folders from VS2010, or TortoiseSVN 1.7 – then it will break IntelliJ projects by updateing the SVN to 1.7).

    Is there any planned date for 11.1 (a week or month is enough, e.g. “end of jan” or “not before may” – in this case I will look for other workarounds how to handle my trouble trifecta here :-)

    Chris

  13. trespasserw says:

    Chris,
    11.1 is planned for release in late Q1/early Q2 2012.
    http://blogs.jetbrains.com/idea/2011/12/subversion-17-support-update/

  14. Kip says:

    I am not able to mount the .dmg file due to invalid checksum. :( mac osx – idea ultimate 11

  15. yole says:

    Kip,
    Please try to download the .dmg file again.

  16. mauro says:

    Please fix WebLogic Server 12c support!
    Currently you can’t deploy web applications with WebLogic.Deployer. As a workaround you can use Autodeploy option as deploy method but this way I have problems to update resources (I’m forced to redeploy every time).

  17. Rickard Öberg says:

    Yup, also got invalid checksum. Downloaded it a couple of times, no difference. Maybe you should, like, check it?

  18. Michael Golubev says:

    Hello,

    Indeed, Weblogic 12c introduced the changes we can’t deal right now,
    please track http://youtrack.jetbrains.net/issue/IDEA-79544 for updates.
    We will hopefully deliver the fix next week, and I will make a local build for the plugin for you to replace the one released in IDEA-11, to allow you to continue before the next 11.0.x and 11.1 releases.

    Regards,
    Michael

  19. yole says:

    Rickard,
    If the .dmg file we uploaded two weeks ago was indeed corrupt, we would have received far more complaints about this. Please try to download using wget.

  20. Hans Zetterberg says:

    I need to purchase IntelliJ IDEA 11.0 but at our company we are also using version 10.5 and the question are, can I use my 11.0 license key to install version 10.5?

    Regards,
    Hasse

  21. yole says:

    Hans,
    Yes, a license key for a particular version of IntelliJ IDEA can also be used with older versions.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">