RubyMine 3.1.1 Update Available

RubyMine 3.1.1, a bug-fix update to RubyMine 3, is available featuring fixes and improvements in many important IDE parts. See the release notes for the list of changes since the last RC.

We highly recommend everyone to update to RubyMine 3.1.1.

Develop with pleasure!
JetBrains RubyMine Team

This entry was posted in Announcement. Bookmark the permalink.

11 Responses to RubyMine 3.1.1 Update Available

  1. Geir-Tore Lindsve says:

    Uhm, you might want to check that link to release notes:

    “Page level restrictions have been applied that limit access to this page.”

  2. Dennis.Ushakov says:

    Thank you, we’ve fixed problem with access.

  3. McNaz says:

    Looking good so far. Great release JetBrains.

  4. Dan says:

    Awesome, thank you!

  5. Bhavin Kamani says:

    Hi,

    I am facing issues with rvm SDK detection. Initially it detected the rvm rubies along with gemset. But once I created and deleted the project, it lost all the SDKs and has revert back to system SDK (I am using OSX 10.6). Even after restarting it fails to detect the rvm rubies. I reinstalled rubymine 3.1 and there it is able to detect without any issues. I created/deleted and recreated the project and still everything works fine. Because of this issue I am not able to switch to 3.1.1. Let me know if I am missing something here.

    Thanks in advance
    Bhavin

  6. Hey Bhavin,
    you could use your IDE preferences (command + ;) to add or delete the gemsets (including the ones that come with rubymine); after that you click “Add new SDK” and direct to your new rvm install (or the one you currently have)…

    My rvm is kept in the home (~) directory
    ~/.rvm/rubies/ruby-1.9.2-p180/bin/ruby (I directed the new sdk to point there…)

    Also, I’ve upgraded my rvm so I use the latest…

    I hope this helps…

  7. mech says:

    Is it just me? I find that editing code in RubyMine is super slow. And I have maxed up MBA with an SSD :(

    Version 3 is not that slow in editing.

  8. freeman says:

    new ruby-debug-base19x (0.11.27) is out, and now debugger in RubyMine 3.1.1 is working great with ruby 1.9.2 and rails 3 !!

  9. Dennis.Ushakov says:

    @freeman, develop with pleasure! =)

  10. Nico says:

    Just upgraded to RubyMine 3.1.1. Now the debugger doesn’t work anymore. I get a message: “Cannot connect to the debugged process … ” Before (or during) RubyMine tries to connect to the debugger, a warning message box flashes up quickly and disappears so fast that I can’t read what it says.

    Any advice? I’m using ruby 1.9.2 with ruby-debug-ide 0.4.17.beta3, ruby-debug-base 0.11.27

    Nico

  11. Bhavin Kamani says:

    Thanks Victor for your reply.

    I have both 3.1 and 3.1.1 installed. In 3.1.1 My rvm gemset is not getting recognized. Gemset below the Ruby SDK is grayed out and says “n/a”. I have the gemset set in .rvmrc file. Whereas in 3.1 everything works fine.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">