RubyMine 4.0.1 Hotfix

Hot news about RubyMine 4 update.

Some of our users reported a major bug about debugger UI we’ve had to fix as soon as possible. Thanks to this quick and important feedback RubyMine is now updated to version 4.0.1. We strongly recommend you to upgrade. Please use “Check for Updates…” to download and install the update as a patch to your existing installation.


Develop with pleasure!
JetBrains RubyMine Team

This entry was posted in Announcement. Bookmark the permalink.

11 Responses to RubyMine 4.0.1 Hotfix

  1. Guido says:

    Adding watches, right? Glad to see it’s fixed so quickly :)

  2. Christopher says:

    Thanks for fixing that so fast. :D It was super annoying.

  3. Ron Jeffries says:

    For help with Test-Driven Development, get in touch! :)

    Great product. Love you guys!

  4. Piotr Hapanowicz says:

    Hi, used to use version 2.0.2, was working good.
    I’ve tried new version 4.0, and some problems was with autoinstalling GEMs, there is no possibility to remove GEM ? no button, no possibility to choose version. But ok.
    Other really disturbing problem is with debugger. When i read today about patch to solve problem with debugger, i installed. But my problem is still the same:

    - during debugging, i can not use step over option, debugger comes in to deeper and deeper methods ?!?!, then option to step out, works not. it hang somewhere, no action, the only i can do is to stop debugger. The only works is to go to cursor.
    Question is am i doing something wrong or what ?
    I use MacOS version of RubyMine …..

  5. Frank says:

    Would love to see a video series of maximizing your productivity with RubyMine. You have a great app, but it’s become so deep that I’m only scratching the surface of it and so it’s really no better than TextMate or such without having a deeper understanding of how to really maximize usage.

    • Wes Shaddix says:

      +1 for video series of how to be productive by utilizing RubyMine features. I’m just getting started with it and know there is a lot of features that I could use to improve my efficiency.

  6. Frank says:

    Oh, and why don’t you guys ship micro updates that integrate through the program rather than making users download the entire package again?

    • Dennis Ushakov says:

      Micro-update from 4.0 to 4.0.1 is available, patch to updated from earlier version was not created intentionally in order to archieve almost-clean-install experience.

  7. Jeff Deville says:

    The macro I used to create a new tab group no longer works. Here’s a screenshot of the commands:
    http://cl.ly/1n0y3L3p0V1H3a2V351r

    This is something I’m doing constantly. Would appreciate any help!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>