RubyMine 4 Beta Update: Rails 3.2 Support and Other Improvements

Hello everyone,

The closer to release date, the more excitement we feel. And it is approaching day by day! In the meantime we are basically focused on cleaning and polishing. Still there are some new features we want to share with you. So please welcome one more beta version: RubyMine 4.0 Beta (build 112.669).

In addition to the ongoing speed, usability and code refactorings improvements we added the following:

  • Thanks to your feedback the latest Rails 3.2 framework is now supported.
  • We also went on with UI improvements and changed the debugging panel design.

Please take a look on the list of changes in release notes. At the threshold of final RubyMine 4.0 build we appreciate your feedback so much! Please feel free to comment on this Beta.


Develop with pleasure!
JetBrains RubyMine Team

This entry was posted in Announcement, Comfort, Cutting Edge and tagged , , . Bookmark the permalink.

10 Responses to RubyMine 4 Beta Update: Rails 3.2 Support and Other Improvements

  1. Leonid Svyatov says:

    Version 112.477 doesn’t see this update on Mac OS :(

  2. Hemant Kumar says:

    I will file a bug report, when I get bit of time, but I noticed the IDE hangs when doing find usage on a medium to large size project. I haven’t seen this before in previous EAP builds of RubyMine.

    • Mike says:

      Ugh. The EAPs have been great until 661. Now RubyMine hangs randomly, or keyboard input stops. I can manage between 0 minutes work up to a maximum of about 10 minutes before I get a beachball….

      How can I help you guys diagnose this awful problem?

  3. evan says:

    in my opinion it takes a lot of memory, current usage: 838 mb under linux, having it at about 400 or less memory would be great!

  4. artemiy says:

    Please return the behavior of searching for files to previous versions. Earlier, during the search, the results were visible at once, and now opens only after the tree is complete. This is a very interfere with the work with a great project!

    • Dennis Ushakov says:

      Is this still a problem with latest beta? I cannot reproduce this issue

      • Artemiy says:

        Yes. Earlier, during the search, the nodes of the tree with the results were open at once, but now they swing open only after a complete search. It is not very convenient on a large project.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">