PhpStorm & WebStorm 4.0 EAP 117.65

The time frame for version 4.0 development is closing so we almost finished introducing new features and focused on bugs, performance and usability.

This week’s EAP brings you fixes and improvements in all areas, with following changes most notable:

  • PHP Completion for simple cases was improved – for class declarations, try/catch clauses, etc.
  • JavaScript got support for Requirejs and ’Go to declaration’ on CommonJS’s AMD format
  • Performance problems introduced with recent PHP 5.4 features were fixed

More details available in build changelog and platform changelog

Please, do not use twitter or blog comments for bug reports, file them to tracker.

Download PhpStorm & WebStorm for your platform from project EAP page.
Patch-update is NOT available.

Develop with pleasure!
-JetBrains Web IDE Team

This blog is permanently closed.

For up-to-date information please follow to corresponding WebStorm blog or PhpStorm blog.

 
This entry was posted in Early Access Preview, PhpStorm, WebStorm and tagged , . Bookmark the permalink.

21 Responses to PhpStorm & WebStorm 4.0 EAP 117.65

  1. Sam says:

    Typos:

    “The the time frame” → ”The time frame”.
    “Performance introduced” → “Performance issues introduced”

  2. Bryan Green says:

    Nice speed. Seems like a good release. I’ll post more comments if I got em.

  3. OZ says:

    I run it and close, and run again. I can’t belive how fast it launches now. I hope nothing is broken in my installation and it’s just new performance of IDE.

  4. Andriy Bazanov says:

    Will http://youtrack.jetbrains.com/issue/WI-2760 make into v4 final .. or will it be postponed yet another time?

  5. elkuku says:

    How do you make it starting up so crazy fast ;)

    Works quite well here – Thumbs up.

  6. Aleksey Deryagin says:

    Nice update, quick and stable :) , thanks!

  7. tufi says:

    …impressive how fast the IDE starts! Nice! Thanx!

  8. Adrian says:

    Since this new release not all WARNINGS are shown inside the editor, so e.g. the warning for “unused local variable” is only displayed in the side-bar to the right, but the variable is not underlined or so. I have a lot of ASSERTS error, which I already submitted to jetbrains.

  9. Jannik says:

    Opening the IDE is not faster for me (using an SSD, so it was always fast).

    But since autocompletion for JavaScript in combination with “this.” is completely broken (in the last EAP also, btw) the current version is not very useful right now (ticket: http://youtrack.jetbrains.com/issue/WI-10459). :-(

    • Jannik says:

      Ok, already fixed. That was fast, nice work!

      Just waiting for the next release (or EAP?) now…

  10. Michal says:

    Hey men! Thanks for Behat support, much easier days to come!

  11. Burak Ueda says:

    Already have 3.0.3 and trying to install 4.0
    First problem when I try to import settings from older version:
    “C:\Program Files (86)\JetBrains\PhpStorm 3.0.3 does not appear to be PhpStorm config folder or installation home”
    Which is not true. Folder and PhpStorm 3.0.3 installation is there.

    So I cannot import settings from 3.0.3?

    • Marco says:

      Same problem for me with the v4.0.1 – not recognizing my previous setting. Event when I point the config import to that directory.

      Help! Thanks!

    • Denis Chmel says:

      Same for me, 3.0.3 -> 4.0.1,
      “C:\Program Files (86)\JetBrains\PhpStorm\ does not appear to be PhpStorm config folder or installation home”

      Plus when clicking [.] button in the input it shows NOT the C:\Program Files (86)\JetBrains\PhpStorm\, but \Users\, maybe it looks for config there too.

Comments are closed.