PhpStorm 4.0: Do It Right From The First Time

Hi from JetBrains!

We’re happy to announce the long-anticipated update to our smart code-centric PHP IDE — PhpStorm 4.0!

To keep pace with the times, the new release includes full compliance with PHP 5.4 language features and ECMAScript Harmony support, and killer bug-prevention abilities using PHP Code Sniffer and PHPUnit Code Coverage. This makes PhpStorm 4.0 a must-have IDE for today’s sophisticated PHP developers.

The most important changes in PhpStorm 4.0 include:

  • PHP 5.4 language features support
  • ECMAScript Harmony support
  • Code coverage for PHPUnit
  • Code checking with PHP Code Sniffer
  • Drupal coding style support
  • New PHP code inspections
  • Smarter JavaScript completion

Read more about what’s new and download PhpStorm 4.0.

NOTE: PhpStorm 4.0 is a free update for everyone who purchased their license after April 25, 2011.

Develop with pleasure!
JetBrains Team

This blog is permanently closed.

For up-to-date information please follow to corresponding WebStorm blog or PhpStorm blog.

 
This entry was posted in PhpStorm, Release Announcements and tagged , . Bookmark the permalink.

45 Responses to PhpStorm 4.0: Do It Right From The First Time

  1. Steve says:

    I think you forgot “time” in the title on the “what’s new” page. But congrats on the release! :)

  2. Sam says:

    Any difference from 401 RC? Build number is the same.

  3. Daniel says:

    Hello. Greate news. I love working with PHPStorm – programing is pleasure now. Where can I find information about what are you planning for 5.0 version ?

  4. Sweet! Will a patch update be available to auto-update from?

  5. Abdullah says:

    Can we patch-update PHPstorm from 3.x to 4 ?

    or should we download and reinstall it ?

    I dont want to lose my configurations :<

    • Alexey Gopachenko says:

      No patch update between major versions

      • Abdullah says:

        So is there a way to update and keep your configurations ? or do you have to re-do all of them ?

        • Alexey Gopachenko says:

          File | Export Settings / Import Settings are always available.

          • Evert says:

            Is it just me or has it become impossible to select individual settings in both the export and import dialog windows? All the checkboxes are checked and I cannot uncheck any of them?

    • Marcin says:

      Previously I had latest version 3.x, I`ve downloaded and run version 4.0.1 and during first start it asked me for config directory of previous version of phpstorm. I pointed to .WebIde10 in my home dir and it works – I have 4.0.1 with my settings from 3.x.

  6. Nikita says:

    I have a problem with a project types, like a Twitter Bootstrap and HTML Boilerplate. I don’t see drop-down list on Create project dialog, but I see info about this feature in the help.
    What am I doing wrong?

  7. John says:

    Did the left/right arrow key functionality change in version 4?

    Previously when I am at the end of a line and press the right arrow it would move down to the next line (like every other text editor) – In version 4 I can now press the right arrow key forever and it will not go to the next line.

    The left arrow key at the start of the line will not take you to the end of the previous line.

    • ZdP says:

      I had the same initial issue! To fix it, just go to the Preferences > Editor and uncheck “Allow placement of caret after end of line”.

    • Andriy Bazanov says:

      Nope — it’s your settings — Settings | Editor | Allow placement of caret after end of line.

  8. Tim says:

    Will us IntelliJ 11 users get the update for the PHP plugin?

  9. G says:

    So it’s not possible to upgrade from 3.x to 4.x. In that case, what are the steps required to install the new version? Do I uninstall 3.x then install 4.x? What about keeping settings from 3.x?

  10. Rafi B says:

    Would love to see SASS compilation support soon..

  11. hardevine says:

    ..at last….we got..4.0…
    ….thank u ….jetbrains team…
    …:-)))

    will it support older plugins…??

  12. Simon F says:

    Finally! :-)
    Looking forward to working with this…

  13. The best PHP IDE ever!

  14. ishowshao says:

    the 4.0.1 download page for mac os x http://www.jetbrains.com/phpstorm/download/
    click the download then a EAP114.158 will be downloaded , not the 117.257, i think the download link to a wrong file !!!

  15. Tama says:

    Phpstorm is awesome, thanks for another great release.

    My only ask if that you please, please update your OSX logo to match your new logo on the about page. Every time I tab to Phpstorm I cringe at the beveling :).

  16. Peppe says:

    I’m a Jetbrains’ big fan but I confess I expected more at a major version release.

    Anyway I think I’m going to use PhpStorm 3 by now, every time a major version is released the php documentation has some trouble.

  17. ufuk says:

    discovered 2 jquery (so JS) bugs. hope to get fixed soon.

  18. Uno says:

    PHP Storm is indeed the best PHP ide ever but like I wrote in previous post it sometimes hangs (no crash, it just hangs and the only thing I can do is to kill the process) on reformatting or replacing operations. Unfortunately it’s hard to reproduce. In my project I selected some part of text and started to replace one word to another. Storm did that (I was able to see the change in the editor) but then hanged. I tried to isolate this problem, so I created a new project, copied the same file and then finally tried to repeat the same operation but this time everything went fine. Then I tried to repeat it in the main project again, but this time no hang as well. Strange.. but for time to time storm just hangs… Hope someone else is experiencing the same.

  19. PHPStorm is awesome and kicks some serious php a**. Very clear, very intuitive, user-geared. A pleasure!
    The debugging feature especially saves a lot of eye strain and hair pulling! Even DrupalDear can’t resist! Thank you!

Comments are closed.