PhpStorm & WebStorm 4.0 RC2 (117.211)

Release Candidate 2 for PhpStorm & WebStorm 4.0 is ready. Notable improvements:

  • Numerous improvements in PHP stubs – for SPL, DOM, ssh2, svn and many others. Please issue File|Invalidate Caches!
  • Spellchecker will skip @author, @link and @file values in PHPDoc to reduce false positives, plus we started work on built-in PHP-specific dictionary
  • Go to Class now supports “namespace\” prefixes to narrow down the search
  • Traits will be suggest in completion for “use” clauses in class
  • ..plus lot of bug and performance fixes in all areas

Please report all problems ASAP – and do not use twitter or blog comments, file them to tracker.

We have fixed lot of recently reported problems and made significant performance improvements for PHP code inspection. More details available in build changelog.

Download PhpStorm & WebStorm for your platform from project EAP page.
Patch-update is NOT available.

Develop with pleasure!
-JetBrains Web IDE Team

P.S. Its the LAST day of Easter special 30% OFF!

This blog is permanently closed.

For up-to-date information please follow to corresponding WebStorm blog or PhpStorm blog.

 
This entry was posted in PhpStorm, Release Announcements, WebStorm and tagged , , . Bookmark the permalink.

6 Responses to PhpStorm & WebStorm 4.0 RC2 (117.211)

  1. koubel says:

    For me, this new EAP is completely useless after while of working, it seems also slowly then previous EAPs and even then 3.x – I create the WI-10796. Has anyone same experience or some advice for me?

  2. Bryan Green says:

    Haven’t used this release enough but it seems fast and peppy. Do you have a lot of validators, spell checking?

    I like this release a lot…

    Did you invalidate your caches and restart?

    • koubel says:

      Yes, I did. I tested this build without any previous caches, data, configs etc. I made a new separated installation and setup for testing project, same as earlier EAPs. This build seems like internally invalid for me.

      • Bryan Green says:

        Perhaps try build 117.222. I just patched up to this.

        As an aside, I’m impressed by the list of ‘Third-Party Software Used by WebStorm and PhpStorm’ link below. That’s more than just a lot of horses under the hood.

  3. Tester says:

    On the downloadsite the new eap is named 117.222

    Is this a new one or just misspelling?

    • Alexey Gopachenko says:

      Definitely a new one. Try “Check for updates”. You’ll get a patch update. BTW we fixed the patcher to be one click :)

Comments are closed.