PhpStorm & WebStorm 5.0 EAP 121.110

This week’s build is focused on fixing and fine tuning old and recently introduced features, both in *Storm specific modules and IntelliJ Platform.

More details on new features are coming in separate posts. More goodies in next build! Right now we are working on PHAR support, various framework-related features and better performance.

Please report all problems to our issue tracker. Bear in mind that all you see is “Work in Progress” and may undergo serious changes.

Download PhpStorm & WebStorm for your platform from project EAP page. Patch-update is also available. IDEA 12 plugins will be available within a day.

Develop with pleasure!
-JetBrains Web IDE Team

This blog is permanently closed.

For up-to-date information please follow to corresponding WebStorm blog or PhpStorm blog.

 
This entry was posted in PhpStorm, Release Announcements, WebStorm and tagged , . Bookmark the permalink.

23 Responses to PhpStorm & WebStorm 5.0 EAP 121.110

  1. Bryan Green says:

    Thanks for the hard work. Bugs never seem to respect the sign “NO LOITERING.”

  2. Danny says:

    PHP files have no syntax highlighting with this version. What an annoying bug! :)

    • Alexey Gopachenko says:

      Well, since you the only one of hundreds of daily downloaders reporting such a significant and obvious problem – I’d say its only you who are unlucky.

      Any further discussion should be moved to Forum – http://www.jetbrains.net/devnet/community/wi/

      • tufan says:

        > Well, since you the only one of hundreds of daily downloaders reporting such a significant and obvious problem – I’d say its only you who are unlucky.

        maybe, many hundreds of other EAP users, just don’t take time to report it, and decide to wait for the next EAP or the stable version?

        I also see problems in the EAP builds (particularly not the syntax highlighting mentioned above, but others) and if these are serious enough, I just use my stable 4.03 Version. Taking time to write this comment to your rude answer “I’d say its only you who are unlucky.” is an exceptional case.

        We’re all developers; and should listen to our users.

      • Danny says:

        I don’t have the time to go register on your forums and I only wanted to give other people a heads up.

        PHP is completely missing from File Types in preferences which is why this is happening I’m guessing. I also tried to delete my preferences completely and start out fresh and experienced the same issue.

        Clearly all this is due to ‘bad luck’.

        • Danny says:

          To follow up, after doing a reinstall and resetting my preferences again everything works now. Perhaps something went wrong during the install.

          • Alexey Gopachenko says:

            So it looks like “unlucky” in the end ;)

            Doing this before a giving other a “heads up” might be good idea – and I can’t see how saying “looks like you are unlucky” is more rude than just yelling “totally broken” w/o any details (and refusing further discussion.)

            The entire Early Access Program idea is “we give you usable free builds, you gave us proper feedback”

  3. EugeneOZ says:

    Still not usable. Now namespaces in phpdoc works wrong, and not found methods are not highlighted as error (not even warning).
    And I don’t see any reason to write issue ticket in tracker, because previous tickets aren’t fixed in previous builds.

    • Alexey Gopachenko says:

      I dont see any recent tickets with *critical* problems from you:
      http://youtrack.jetbrains.com/issues/WI?q=%23Unresolved+created+by%3A+Zyava+order+by%3A+created+

      And we don’t have other “IDE not usable” reports.

      So unless you wish to stick with 4.0.3 forever – file it – with details.

      • OZ says:

        My login there isn’t Zyava, very important issues for me is WI-12524 and WI-12525. I’m checking them in each build and they are still reproducible, so I can’t switch to 5 EAP.

        Don’t hate your users for found bugs. And your “I’d say its only you who are unlucky” in another answer is not your smartest answer.

        PhpStorm is still best PHP IDE, but unless you wish your users to stick with 4.0.3 forever, please don’t be so rude and fix stability bugs first (because it’s not convenient work when IDE shouts about fatal errors each few minutes).

    • Andriy Bazanov says:

      > “and not found methods are not highlighted as error (not even warning).”
      I confirm this.

      Currently I’m just doing a quick check on how my code looks in new EAP builds and then back to v4 for daily usage.

  4. Danny says:

    Why did you delete my comment? It was just a heads up to others who may think about upgrading to this EAP (I consider it unusable because of it, since coding PHP with no colors is a mess). Oh well.

  5. Danny says:

    Sorry, forgot comments are moderated. I’m an idiot. :D Pls delete this and previous comment.

  6. Kifah Abbad says:

    Where can i find details about the frameworks support? specifically Symfony 2+

  7. Nazar says:

    Still getting constant “File Cache Conflict” dialog. See IDEA-89247.

    This bug makes WS pretty much useless unless you enjoy loosing/overwriting code as that dialog only shows up after the the fact (i.e. once time has been spent writing code and on saving)

  8. akim says:

    This version is infinitely indexes project, scores memory, hangs until clears memory, and then again continues to index. And so indefinitely. Apparently, therefore, in many classes periodically disappears suggests.
    I associate it with the addition of support frameworks (using yii)

  9. I can confirm the indexing issue @akim speaks of. I’m on OSX 10.8.2…

Comments are closed.