IntelliJ IDEA 2018.3.1 RC is here!

Yesterday was a big day for us, as we released IntelliJ IDEA 2018.3! Today we are ready to give you the first RC build for the upcoming bug-fix update v2018.3.1.

Download IntelliJ IDEA 2018.3.1 RC build from Confluence or take this update from the Toolbox App, or if you’re running IntelliJ IDEA 2018.3 – install the patch.

Please note that the RC build requires an active license for IntelliJ IDEA Ultimate.

IntelliJ IDEA 2018.3.1 RC build comes with the various improvements and bug-fixes. For a start, it is now possible to use multiple $Prompt$ macro in External Tools: IDEA-129070

We’ve added a couple of small improvements to the Java Scratch files too, and now the IDE proposes to modify any ‘throws’ for the methods in scratch files, and suggests the “change type” quick fix for class fields.

In other news:

  • The broken “Select in…” in new Search Everywhere is fixed: IDEA-197872
  • We fixed the replace for the pre-selected text: IDEA-200011.
  • Various improvements have been made in Spring Cloud Stream: IDEA-201865, IDEA-201867, IDEA-201605.
  • Fixed the problem when a wrong module dependency was resolved when the source set output folders are used as the project dependency configuration artifacts: IDEA-202271.

See the release notes for the full list of improvements.

Please use our bug tracker to report any issues you encounter, and don’t forget to share your feedback with us on our discussion forum, Twitter, or here in the comments!

Happy developing!

About Zlata Kalyuzhnaya

IntelliJ IDEA Marketing Manager at JetBrains. twitter: @ZlataKalyuzhnay ‏
This entry was posted in Release Candidates. Bookmark the permalink.

8 Responses to IntelliJ IDEA 2018.3.1 RC is here!

  1. Dmitry says:

    There’s a typo in the text: IntelliJ IDEA _2017_.3.1 RC build comes …

  2. Pingback: IntelliJ IDEA 2018.3.1 RC 发布,bugfix 版本 – ITmax-

  3. JR says:

    Any plans for some dropwizard awareness in future version?

  4. Alon says:

    What about the IBM JDK fix, https://youtrack.jetbrains.com/issue/IDEA-201089?
    It’s urgent. I already upgraded to 2018.3 and I can’t compile my code!

  5. MiKuhl says:

    I upgraded to 2018.3 RC, I do have a active licence (Subscription is active until Feb 2019) but the license is not accepted any more. I am effectively locked out of my dev environment..!

    please advise…

  6. Vicky Ronnen says:

    Liquigen 0.0.5 no longer supported?
    Any alternative available?

Leave a Reply

Your email address will not be published. Required fields are marked *