AppCode 2.5 EAP: ビルド #131.144リリース – Xcode 5 GMと64ビットiOSサポート

本日新しいAppCode Early Access ビルドをリリースしました。Xcode 5 GMと64ビットのiOSシミュレータをサポートしています。

気になる点などございましたら是非掲示板YouTrackへ声を寄せてください。

Xcode 5との連携についてはいくつか既知の問題があります:

  • コンパイルリポートで‘Failed to register MobileDevices.bundle’エラーが表示される問題。これは無害なので無視して頂いてかまいません
  • 運良く64ビットデバイスを手に入れた方:64ビットアプリケーションの64ビットデバイス上でのデバッグはうまくできない可能性があります
  • シミュレータ上でのユニットテストのスタンドアロン実行は‘Run’モードでハングすることがあります。launchd_simプロセスツリーをkillするか、‘Debug’モードを使うことで回避できます

これらの問題はできる限り早く修正できるよう対応中です。

他に特筆すべき点としてはデバッガにおける‘Set Value’機能の改善、CocoaPodsサポートのマイナーな問題の修正、より強化されたC++言語サポートがあります。さらにtypedparameterized Google Testsをサポートしました。

修正内容はこちらで一覧できます。

こちらからダウンロードし、是非感想をお聞かせください!

Develop with pleasure!


The AppCode チーム

This entry was posted in AppCode. Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *