2018 年及更早的 YouTrack Workflow 需要您尽快迁移

Lei

如果您的团队在 2018 年或更早的时候加入 YouTrack,请向您的系统管理员和项目管理员展示本博文。

某些 YouTrack 客户仍然依赖旧版本的 Workflow,这些 Workflow 将于 2020 年 11 月弃用。 我们建议您检查一下这是否会对您造成影响,如果会造成影响,请采取措施。 请继续阅读以了解更多信息。

什么是旧版本 Workflow??

旧版本 Workflow 是指在旧版 Workflow 编辑器中编写的工作流,该编辑器在 YouTrack 2018.3 及更早版本中是外部应用程序。
我们在 2019 年正式停止了对旧版本 Workflow 的支持。 在定于 11 月发布的 YouTrack 2020.5 中,我们计划完全移除支持旧版本 Workflow 的逻辑。 因此,任何附加到 YouTrack 中项目的旧版本 Workflow 都将无法正常运行。
如果您的任何项目依赖这些 Workflow 来支持您的业务流程,请尽快将其迁移到 JavaScript 的版本。 有关如何检查 Workflow 的详细说明,请阅读此篇博文

2020 年 11 月会发生什么??

对于 YouTrack 独立版,从 2020.5 版开始,YouTrack 将检查您的项目中是否使用了任何旧版本 Workflow。 只有在停用这些 Workflow 后,才能升级到新的 YouTrack 版本。
对于 YouTrack InCloud,旧版本 Workflow 将从 2020.5 版开始停止工作。 请注意,一旦 YouTrack 2020.5 发布,我们将无法延迟升级您的 YouTrack InCloud 服务器。 这就是我们强烈建议您提前检查您的 Workflow 的原因,以便根据需要为迁移留出足够的时间。
请用这段时间来清点您的 YouTrack Workflow,并尽快更新所有旧版本 Workflow。
如果您对将 Workflow 迁移到 JavaScript 有任何疑问或需要帮助,请联系我们的支持团队或加入 Slack 上的 YouTrack 社区。 我们将随时为您提供帮助!

您的 YouTrack 团队

订阅

订阅产品动态