PhpStorm 7.1.1 bug fix update is available

PhpStorm 7.1.1 build 133.679 is available for download.

This update is focused on various bug fixes and improvements from the PHP, web & IntelliJ platform sides.

The most important changes include:

If you experience any issues with PhpStorm icon on Linux, please see this comment to resolve it.

Download PhpStorm 7.1.1 build 133.679 for your platform and please report any bugs or feature request to our Issue Tracker.

Patch-update from the previous stable version (PhpStorm 7.1) will be available in an hour.

Develop with pleasure!
-JetBrains PhpStorm Team

This entry was posted in Release Announcements and tagged . Bookmark the permalink.

52 Responses to PhpStorm 7.1.1 bug fix update is available

  1. ag483 says:

    No Blade template support?

  2. moody says:

    Great list of improvements!
    Multi-cursor support? please!?? :)

  3. Vladimir says:

    Is it me and my fault or do others have problems with PHPStorm themes (http://phpstorm-themes.com/). Neither one of those, not .xml nor .icl do work on my installation (Win7).

  4. Nicole Cordes says:

    No patch-update from previous EAP version (133.626) available?

  5. Vasa says:

    “Patch-update from the previous stable version (PhpStorm 7.1) ”

    Felt great!!!!

  6. Matthias says:

    Thank you so much! Great job!
    Love the new menu bar

  7. Rafi B. says:

    I can never understand these programmers who have nothing better to ask than the auto-update.
    Thanks JetBrains for a great release cycle!

  8. Carsten Decker says:

    IDEA-17359 is not fixed for me in 133.679

  9. Ben says:

    What about this issue? Is this somehow on the roadmap?

    http://youtrack.jetbrains.com/issue/IDEA-114351

    this really is so annoying for windows users cannot understand why this has not been assigned yet. Prevents me from upgrading

  10. AlexP says:

    Sometime I cannot type anything in PHPStorm editor, also cannot switch tab using ctrl-tab shortcut (I still can move the cursor). To resolve it, I have to close PHPStorm and reopen it. This is really annoying.
    I encouter this problem mostly in Linux (Ubuntu 12.04,Linux mint 15,16 | Oracle JDK 1.7)

  11. Dejan says:

    I was using PhpStorm 6 on Ubuntu 13.04 and everything worked and looked really awesome. Now I updated it to PhpStrom 7 and all the letters are really bigger (including all the menus, windows and editor). I tried to fix them in the preferences but didn’t succeed.

    P.S. I’m using the Darcula theme.

    • Mikhail Vink says:

      Could you please try File | Invalidate Caches? Please also check that you don’t have tweaks in Settings | Appearance | Override default fonts…

  12. Konstantin says:

    This bad-bad-BAD update!
    Remote host stupid in this version. In 7.0 remote host good work.

    If I click button [...] in “Root path” and remote server don’t long responsible, after click “cancel” all PhpStorm stopped.

    Thanks.

  13. Olexander says:

    This update break auto completion for me. When one class extends another then auto completion don’t work. I am using IntelliJ IDEA 13 on Ubuntu 13.10 with php plugin. My friend who using phpStorm 7.1.1 also faced with this bug.

    And I have this error:

    6:01:36 PM AbstractMethodError: com.intellij.webcore.template.formatter.AbstractTemplateLanguageFormattingModelBuilder.createTemplateLanguageBlock(Lcom/intellij/lang/ASTNode;Lcom/intellij/psi/codeStyle/CodeStyleSettings;Lcom/intellij/formatting/Indent;Lcom/intellij/formatting/Alignment;Lcom/intellij/formatting/Wrap;)Lcom/intellij/formatting/Block;: com.intellij.webcore.template.formatter.AbstractTemplateLanguageFormattingModelBuilder.createTemplateLanguageBlock(Lcom/intellij/lang/ASTNode;Lcom/intellij/psi/codeStyle/CodeStyleSettings;Lcom/intellij/formatting/Indent;Lcom/intellij/formatting/Alignment;Lcom/intellij/formatting/Wrap;)Lcom/intellij/formatting/Block;

  14. Wesam Alalem says:

    Thanks for the fixes.
    keep up the great job :)

  15. Chris says:

    Please schedule some time to take care of the smaller usability-related bugs that are accumulating. Remember, that while there are users that are always wanting the latest new features added, there are also those who care more about making the existing product easier to use. Bugs like these:

    http://youtrack.jetbrains.com/issue/IDEA-114351
    http://youtrack.jetbrains.com/issue/IDEA-97641
    http://youtrack.jetbrains.com/issue/IDEA-91530
    http://youtrack.jetbrains.com/issue/IDEA-96651

    They stagnant for months, or even more than a year. My subscription is up in Feb, and I really see no reason to renew – the things you are adding I don’t care about, and you seem to put no effort into polishing the rough edges.

    I’m impressed with how quickly you add new features, but please… pause for a bit and clean house a little.

  16. So is a patch update for a stable release already available?

    It’s 131.374 build installed and it only proposes to download the complete installer.

    • Mikhail Vink says:

      Yes, the patch has been available for latest stable release (7.1), but not previous 7.0. 131.374 is 7.0, so you should download a full 7.1.1 copy.

      • It’s weird. Any plans to allow 7.0 -> 7.1 -> 7.1.1 patch updates or at least introduce scheduled update checks?

        I don’t restart phpstorm for weeks thus missing updates

        • Mikhail Vink says:

          For now updates also can be also checked manually at Preferences | Updates. 7.0->7.1 patch hasn’t been issued this time because of branch switch, but we’ll try to issue that the next time.

  17. Anatoly says:

    As for me 7.1.1 very slow that 7.1 I don’t know why :-(

  18. Pingback: Alliberat PHPStorm 7.1.1 « CODI Ç

  19. Time to update your copyright notice to 2014. :)

    https://cloudup.com/cBo8WYo8Xst

  20. Dmitry says:

    Great job! Is there any chance to get codeigniter support ?

  21. James says:

    I am new to PHPStorm so haven’t done the update process before. Do I have to download the entire application again or is there a patch? Clicking download from the program directs to this page

    • Mikhail Vink says:

      It seems you are using the version where patch updates is not available. Please download a full version. Thank you!

  22. Philippe says:

    Would it be possible to upgrade included SVN client to support 1.8 working copy format?
    SVNKit 1.8.3 supports it ;)

    • Mikhail Vink says:

      Well, PhpStorm 7.1 and 7.1.1 already supports SVN 1.8 via native client. Please update your IDE to the latest version and that should resolve the issue.

  23. Philippe says:

    Wrll I still get the error message:
    “URL: svn: E155021: E155021: This client is too old to work with the working copy at ‘C:\projets\XXX’ (format 31). You need to get a newer Subversion client. For more details, see http://subversion.apache.org/faq.html#working-copy-format-change
    Format: 1.8

    The path mentionned is a TortoiseSVN 1.8.4 working wopy.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>