PhpStorm 8 EAP 136.1382

PhpStorm 8 EAP 136.1382 is available for download.

From the PHP side, this build brings:

  • PHP remote interpreters support – use PHP interpreter over SSH installed on any remote environment to run/debug application and run testing tools remotely
  • PHPUnit can be run via SSH
  • Multiple PHPUnit configuration are now supported for remote interpreters
  • WordPress support: list of functions that supports action/filter as parameter is extended
  • WP-CLI and Composer command-line tool is able work with pure executable now
  • and much more (see full list in our issue tracker)…

WebStorm 8 has been released a couple of days ago and all the WebStorm’s new features and improvements are already included in this PhpStorm 8 EAP.

IntelliJ platform also features many bug fixes and improvements.

See full release notes for a list of changes.

Download PhpStorm 8 EAP build 136.1382 for your platform from project EAP page and please report any bugs and feature request to our Issue Tracker.

Patch-update will be available in an hour from the previous PhpStorm 8 EAP build (136.1255).

Develop with pleasure!
-JetBrains PhpStorm Team

This entry was posted in Early Access Program and tagged . Bookmark the permalink.
  • Seth Thornberry

    Is there any documentation on the remote interpreters yet? I’ve been kind of muddling through it and I’m having some trouble figuring out how to specify PHPUnit to use the remote interpreter I defined..

    • Svetlana Zemlyanskaya

      Once you have remote interpreter configured you can create remote PHPUnit configuration at PHP|PHPUnit (press add and select “By Remote Interpreter”). That’s all. You can use the same run configuration as for local PHPUnit, just make sure that the proper (the remote one) interpreter is selected at the PHP settings.

  • Eugene OZ

    WebStorm has AngularJS advanced support – when it will be implemented for PHPStorm? Is it in your plans?

    Please consider to create video presentation of new PHP Remote Interpreter feature – very interesting thing.

    • Vukasin N.

      Fully agree with @Eugene OZ

      BTW: JetBrains, you are doing amazing job.

    • Mikhail Vink

      In fact, AngularJS support is already in PhpStorm with free plugin at http://plugins.jetbrains.com/plugin/6971?pr=phpStorm so feel free to install it in Settings | Plugins.

      We are going to cover PHP Remote Interpreter feature by tutorial/blog post in the nearest feature (ETA 1-1.5w), and video tutorials will be made closer to the release when feature-related UI is finally finished.

      • Eugene OZ

        But I don’t see nothing of promised features of AngularJS support with that plugin in PHPStorm.

        • Andriy Bazanov
          • Eugene OZ

            angularjs.min from CDN (and in libraries settings)
            bower installed
            AngularJS plugin installed

            don’t know what to check else.

          • Andriy Bazanov

            Accordingly to the video and actual text in that blog post, you should use not minified version of angular.js

          • Eugene OZ

            Well, actually, word “minified” can be found only in comment to that (and this) post, but thanks anyway :)

          • Eugene OZ

            Finally it works, thank you very much.
            Next problem – how to disable /dist indexing (without excluding it, to be able commit).

          • Andriy Bazanov

            Video + post text — they all mention “angular.js” file and not “angular.min.js” — that’s what I’ve meant to say. But yes — comment in that blog post now also mentions that specific fact and it’s the only place where I have found “not minimized” word

  • Tommy Bergeron

    Keep up the good work, it’s always a breeze to use your software. The only disappointment I have is that I bought PHPStorm 7 for its Laravel support when in reality it was an incomplete support and now I’ll end up paying a 50$ upgrade fee to finally get Blade templating support… I’ll throw my money at you anyway since you work so hard to please everybody hehe

  • Jim Cummins

    I’m having the same problem as Eugene OZ. I have bower installed, angular shows up in the bower settings inside of PHPStorm EAP, but when I try to add any ng- attributes to my .html file, I get no autocompletes. If it helps, I generated my app with this project: https://github.com/diegonetto/generator-ionic

  • Artem Gordinsky

    Hey guys,
    Do you have an approximate release date set for PhpStorm 8?
    Thanks.

  • Pingback: PHP Remote Interpreters Support in PhpStorm 8 EAP | JetBrains PhpStorm Blog

  • http://NathanArthur.com Nathan

    Is there a way I can be notified when PHPStorm 8 is released?

    • Mikhail Vink

      Yes, sure, please subscribe to our newsletter at http://www.jetbrains.com/phpstorm/ (in the bottom, on the right of social media buttons, “Email PhpStorm news to me”).

  • Andrii

    I have problem with VCS SNV it doesn’t save my credentials….