PhpStorm 8 EAP 136.1575

PhpStorm 8 EAP 136.1575 is available for download.

From the PHP side, this build delivers:

  • Support for PHPUnit Coverage using PHP remote interpreters
  • Indexing performance improvements
  • and many other bug fixes and improvements (see full list in our issue tracker)…

IntelliJ platform and web changes are also included.

See full release notes for a list of changes.

Download PhpStorm 8 EAP build 136.1575 for your platform from project EAP page and please report any bugs and feature request to our Issue Tracker.

Patch-update will be available in an hour from the previous PhpStorm 8 EAP build (136.1476).

Develop with pleasure!
-JetBrains PhpStorm Team

This entry was posted in Early Access Program and tagged , , . Bookmark the permalink.

20 Responses to PhpStorm 8 EAP 136.1575

  1. William says:

    getting an error whenever i launch phpstorm now after the update

    Cannot read scheme _.xml from ‘$ROOT_CONFIG$/tools’: Argument 0 for @NotNull parameter of com/intellij/tools/Tool.setGroup must not be null

    http://puu.sh/8336n.png

    anyone ese getting it too?

  2. Nicole Cordes says:

    No patch-update so far

    • Mikhail Vink says:

      We’ve checked and there is a patch-update from 136.1476 to this EAP, so everything should be fine. Please check that you have updates for EAP enabled in Settings | Updates.

  3. Jon Purcell says:

    I have a license that doesn’t expire until December but once I upgraded it says it expires on May 9th. Will I need to purchase another license?

    • Andriy Bazanov says:

      No.

      EAP builds have their own license which cannot be replaced. Every build has new 30-days license. It’s done so that you do not stay on old EAP build forever (as main purpose of EAP builds is gathering feedback on new features/fixes before it goes public/stable release).

      Once final/release version will be released (i.e 8.0), you will be able to re-enter your existing license.

  4. Kirill says:

    Terminal font became ugly on Linux. How can I change it?

    • Steven says:

      Second that.

    • Mikhail Vink says:

      Settings | Editor | Colors & Fonts | Console Font

      • Jared says:

        Having the same problem, but when I go to change the settings in either font or console font, I can’t make any changes. “Show only monospaced fonts” is checked and Primary font is set to Source Code Pro, but both are greyed out.

        Is there another setting that’s not allowing me to change those settings?

  5. Steven says:

    The “Report to jetbrains” button is disabled, so I’ll post my report here:

    Exception in plugin PHP. 20 minutes ago. Occurred 11 times since the last clear.
    Error message:
    pl.projectspace.idea.plugins.php.behat.BehatJavaExtension.getDataObject(Lcom/intellij/openapi/project/Project;)Ljava/lang/Object;: pl.projectspace.idea.plugins.php.behat.BehatJavaExtension.getDataObject(Lcom/intellij/openapi/project/Project;)Ljava/lang/Object;

    My comment:
    That's whenever I run a custom remote tool Behat (under Tools > subfolder > Behat) configured as follows:
    Name: Run Behat features
    Group: Centr.al
    Description:
    Options: all checked except "Show console when standard error changes"
    Show in: all checked
    Connection settings: Deployment server (config follows below): centric
    Tool settings:
    Program: /www/v1/bin/behat
    Parameters:
    Working directory: /www/v1

    -- Deployment server config --
    Name: centric
    Connection tab:
    Type: SFTP
    SFTP Host: centric (a Debian 7 VM)
    Port: 22
    Root path: /www/v1
    User name: steven
    Auth type: Password
    Password: ****** (Save password checked)
    Advanced options:
    Browse files on server:
    Web server root URL: http://centric (locally mapped to the VMs IP)
    Mappings tab:
    Local path: /home/steven/www/hosts/centric
    Deployment path on server 'centric': /
    Web path on server 'centric': /rosa/rugosa (Apache config follows)
    Excluded Paths tab:

    -- Apache config --

    ServerAdmin webmaster@localhost

    ServerName centric

    Alias /rosa/rugosa /www/v1/public
    Alias /rosa/alba /www/v2/public

    DocumentRoot /www/public

    DirectoryIndex index.html index.php
    Options FollowSymLinks ExecCGI
    AddHandler fcgid-script .php
    FCGIWrapper /usr/lib/cgi-bin/php5 .php
    AllowOverride Indexes
    Order allow,deny
    allow from all

    Options FollowSymLinks MultiViews ExecCGI
    AddHandler fcgid-script .php
    FCGIWrapper /usr/lib/cgi-bin/php5 .php
    AllowOverride None
    Order allow,deny
    allow from all

    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^www/v1/public/(.*)$ index.php?_url=/$1 [QSA,l]

    Options FollowSymLinks MultiViews ExecCGI
    AddHandler fcgid-script .php
    FCGIWrapper /usr/lib/cgi-bin/php5 .php
    AllowOverride None
    Order allow,deny
    allow from all

    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^www/v2/public/(.*)$ index.php?_url=/$1 [QSA,l]

    :

    ErrorLog ${APACHE_LOG_DIR}/001-centric-error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel debug

    CustomLog ${APACHE_LOG_DIR}/001-centric-access.log combined

    • Steven says:

      Ok so apparently it’s the Behat plugin that’s causing these errors. Filed an issue on the Github page of the plugin.

  6. Sebastian says:

    tested spy-js plugin -> not working for me

    The proxy seems to work, session store shows many .json files, but phpstorm “Trace Run” tab says “No events captured”.

    Has anyone else tried that out?

    • Liubov Melnikova says:

      Sorry for misleading. This is not a bug. Please update spy-JS plugin (Settings (Preferences for Mac) | IDE settings | Plugins).

  7. Clemens Tolboom says:

    I still have to edit the Mac OSX version to use the correct Java version.

    That is change /Applications/PhpStorm EAP.app/Contents/Info.plist

    JVMVersion
    1.7*

    When will that be gone?

    • Liubov Melnikova says:

      At the moment all our products require Apple JDK 1.6 to be installed in order to run on Mac. JDK 1.7 from Oracle is not officially supported yet. For now we don’t have ETA on support JDK 1.7.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">