PhpStorm & WebStorm 4.0 Beta (EAP 117.132)

The time frame for new features in 4.0 is closed and todays EAP is a Beta – we will focus on performance and bugs from now on.

Please report all problems ASAP – and do not use twitter or blog comments, file them to tracker.

    More details on build changes available in build changelog and platform changelog

    Download PhpStorm & WebStorm for your platform from project EAP page.
    Patch-update is also available.

    Develop with pleasure!
    -JetBrains Web IDE Team

    This blog is permanently closed.

    For up-to-date information please follow to corresponding WebStorm blog or PhpStorm blog.

     
    This entry was posted in PhpStorm, Release Announcements, WebStorm and tagged , , . Bookmark the permalink.

    12 Responses to PhpStorm & WebStorm 4.0 Beta (EAP 117.132)

    1. Alexey Gopachenko says:

      Please wait a hour for CDN to settle down and downloads will become available for everybody.

    2. Sam says:

      Hello,

      is there a chance that jetbrains is going to release 4.0 till 08.April?
      What is the plan?

      Sam

      • Alexey Gopachenko says:

        We usually do not disclose exact release dates. I can only tell its SOON.
        Why are you asking? :)

        • Sam says:

          hmmm,

          you got me ;-)

          i’m asking because till this date i’m entitled to a free update ;-)

          • Alexey Gopachenko says:

            Well, 08.April is like what – 4 days from today’s beta? Not THAT soon, sorry.

    3. Vladislav says:

      still no symfony support even in 4.0?

    4. Vladimir says:

      So no Symphony nor any other framework. And for future versions only Zend and Symphony FW support. Sorry to say, but no more subscriptions from me when this one ends in July.

      • Alexey Gopachenko says:

        Well, roadmap is not complete, yet, indeed, all framework-specific features are definitely not the top priority. Too much basic stuff to improve. And THEN it will be easier to add framework features.

    5. koubel says:

      4.0 has different – WI-10547, WI-10323 – and buggy WI-10489 phpdoc inspection and completion compared to 3.0.

      I think all above mentioned issues can be classified as regressions and bugs, most of these has no fixed version set, although were reported for previous 4.0 EAP.

    6. koubel says:

      also consider WI-10482 – required phpdoc @throws everywhere

    Comments are closed.