PhpStorm & WebStorm 4.0.1 RC (117.257)

Release Candidate 4 for PhpStorm & WebStorm 4.0.1 is ready. Notable improvements:

  • Numerous improvements in PHP stubs. Please be sure issue File|Invalidate Caches!
  • PHP editor will warn on all incorrect overrides (e.g. final, lower visibility etc.)
  • TypoScript support as downloadable plugin (Settings|Plugins|Browse)
  • ..plus various bug and performance fixes. See build changelog.

Please report all problems ASAP – and do not use twitter or blog comments, file them to tracker.

Download PhpStorm & WebStorm for your platform from project EAP page. Patch-update is also available.

Develop with pleasure!
-JetBrains Web IDE Team

This blog is permanently closed.

For up-to-date information please follow to corresponding WebStorm blog or PhpStorm blog.

 
This entry was posted in PhpStorm, Release Announcements. Bookmark the permalink.

16 Responses to PhpStorm & WebStorm 4.0.1 RC (117.257)

  1. Sam says:

    Aren’t caches invalidated automatically?

  2. Linas says:

    How about PHPStorm 4? Any news about release date?

  3. Dmitry Smirnov says:

    Looking forward for
    http://youtrack.jetbrains.com/issue/WI-7943
    fix.

    Thank you for an excellent software.

  4. Simon Schick says:

    Thanks for removing the warning when running on Linux using OpenJDK. I personally think there’s no big performance-difference now.

    • Aleksey Deryagin says:

      +1 about OpenJDK warning, I work with PHPStorm on OpenJDK 6-7 several months without any Java-related problems, Ubuntu 11.10 mostly and 12.04 last month. Looking for PPHStorm 4 release now, good luck and thanks for frequent EAP updates )

    • +1 to that, works great on ubuntu 10.10+… that warning was well annoying, especially since OpenJDK is the system default java install

  5. Cody Bonney says:

    Thanks for the frequent EAP updates. Looking forward to the release of version 4.

  6. Uno says:

    Unfortunately since few builds phpstorm freezes during replacing operation or reformatting code. At least this happens on my machine.

  7. elkuku says:

    +1 for removing the OpenJDK warning – working several month on OpenJDK without any issues now :)

  8. Matt says:

    Not seeing 117.257 on the DL page, nor as a patch update in 4.0. Any ideas?

  9. Michael Topor-Grabowski says:

    I like phpstorm, but why there ia no normal update.
    Each time i have to install a new version. I have now 5 version with about 1.5 GB on disk.
    It does not get the config an each time you have to spend time to get it work.

    Please implement an normal update, that’s usual for years in software.
    Looking forward to getting it in the future.

    Thx, good work bisides this in fact and i like it ;-)

  10. Michael Topor-Grabowski says:

    and key have to insert again, and configurate jira… annoying

  11. Keltanas says:

    Set a build 117,257 and did not find the menu item Git “Change Tracked Branch”. He was severely lacking in the work. I worry whether he will be in the final release?

Comments are closed.