Edu IDEs EduTools Releases

EduTools Plugin 2022.5 Is Available

With this release, we’re continuing to improve plugin quality by focusing on bug fixes. Here are the highlights:

EDU-4869: The issue with the wrong compiler being used when submitting a solution to Codeforces has been fixed.

EDU-4512: Fixed the bug with wrongly displayed “Python courses not supported” messages when using IntelliJ IDEA with the EduTools and Python plugins.

For the full list of issues addressed in EduTools 2022.5, see our issue tracker.

You can install the EduTools plugin or update it to the latest version right from Settings (Preferences for macOS) | Plugins in IntelliJ IDEA, PyCharm, WebStorm, Android Studio, CLion, PhpStorm, or GoLand.

IntelliJ IDEA Edu and PyCharm Edu 2022.1.1

We’ve released the 2022.1.1 versions of PyCharm Edu and IntelliJ IDEA Edu. These include the latest changes from PyСharm Community 2022.1.1 and IntelliJ IDEA Community 2022.1.1 and the latest EduTools plugin updates from v2022.5. You can download the new builds from our website, use the Toolbox App, or use a snap package on Ubuntu.

Please share your feedback here in the comments, on Twitter, or through our issue tracker. We are looking forward to hearing your thoughts and ideas!

Your Educational Products team