JetBrains MPS 3.3.2 released

Having fixed a few more issues we’re now releasing MPS 3.3.2 to share all the fixes with our users. The release notes will give you the details about the individual problems corrected in this version.
Additionally, the user guide is being constantly updated to provide up-to-date information and, in case you missed the memo, a polished pdf variant of the user guide is now available.

The Drive to Develop
-JetBrains MPS Team

This entry was posted in Announcement and tagged , , . Bookmark the permalink.

7 Responses to JetBrains MPS 3.3.2 released

  1. Sérgio Ribeiro says:

    I’m giving a try on IntelliJ 16 EAP and I can’t use MPS. I put the “MPS IntelliJ IDEA plugin” in the appropriate folder, but the log states the following:

    INFO – llij.ide.plugins.PluginManager – Plugin ‘MPS Core’ can’t be loaded because: Plugin since-build or until-build don’t match this product’s build number
    INFO – llij.ide.plugins.PluginManager – Plugin ‘MPS Build languages’ can’t be loaded because: Plugin since-build or until-build don’t match this product’s build number
    INFO – llij.ide.plugins.PluginManager – Plugin ‘MPS BaseLanguage support’ can’t be loaded because: Plugin since-build or until-build don’t match this product’s build number
    INFO – llij.ide.plugins.PluginManager – Plugin ‘MPS Testing’ can’t be loaded because: Plugin since-build or until-build don’t match this product’s build number
    INFO – llij.ide.plugins.PluginManager – Plugin ‘MPS Version Control support’ can’t be loaded because: Plugin since-build or until-build don’t match this product’s build number

    I have the most current IntelliJ 16 EAP’s version (144.3600.7) and, opening MPS plugin, I find the following declaration in plugin.xml files:

    Is there a way to override this test?

  2. Vaclav Pech says:

    Hi Sérgio,

    MPS 3.3 only supports the officially released IDEA versions, i.e. IDEA version 15. IDEA 16 will be supported by the upcoming MPS 3.4 EAP releases, though.

    Vaclav

    • Sérgio Ribeiro says:

      Hello Valclav and thank you for your response.

      This is bad for testing: I was evaluating IntelliJ 16 EAP (as my real project it’s not for now) and this made me use IntelliJ 15.
      Some workaround to this version validation should exist, either on the MPS plugin side or in the IntelliJ side…
      Maybe IntelliJ EAP versions could have an “Impersonate Last Official Version” feature we could activate :-)

      Regards,

      Sérgio Ribeiro
      Porto – Portugal

  3. Vaclav says:

    Hi Sérgio,

    this would be quite risky, since the plugin API in IDEA 16 may differ from the one in IDEA 15. You could try to manually change the plugin.xml files in plugins and the mps-core.jar file by replacing the line “” with “”.

    Vaclav

  4. Vaclav says:

    Sorry, the suggested change should have been:
    from: idea-version since-build=”143.1″ until-build=”144.1″
    to:

  5. Vaclav says:

    to: idea-version since-build=”143.1″ until-build=”145.1″

  6. Sérgio Ribeiro says:

    Code with lesser-than/greater-than characters don’t work very well here… now I see that my first comment missed a line too :-)
    I agree with you Vaclav, but as EAP versions are for developers and not for production code, I think it would be easily accepted if something like that ruined some code…
    Oh, just to let you know, after my last comment I’ve opened a topic at “IntelliJ IDEA-based IDEs” forum with my thoughts.

    Regards,

    Sérgio Ribeiro
    Porto – Portugal

Leave a Reply

Your email address will not be published. Required fields are marked *