PyCharm 5 and 2016.1: PyPI Compatibility Hotfix

Posted on by Ernst Haagsman

The Python Package Index (PyPI) has recently upgraded its caching infrastructure, which broke our integration with their service. We contacted them to restore this functionality temporarily, and now we’ve prepared a hotfix to make sure earlier PyCharm versions will continue to work into the future.

If you are using PyCharm 5 or PyCharm 2016.1 please update today (Help | Check for Updates) to make sure you won’t be affected when PyPI deactivates their now deprecated API.

Full installers for previous versions of PyCharm can be downloaded from the previous versions confluence page.

-PyCharm Team

Comments below can no longer be edited.

3 Responses to PyCharm 5 and 2016.1: PyPI Compatibility Hotfix

  1. nbro says:

    January 24, 2017

    Trying to update by clicking on “update”, then “restart and install”, but the button “update” keeps on appearing after PyCharm has restarted.

    • Ernst Haagsman says:

      January 24, 2017

      These versions of PyCharm aren’t the newest version. After you’ve applied the hotfix, it is letting you know that there’s a newer version of PyCharm out there (2016.3.2). If you click ‘update’, you can then click ‘Ignore this Update’ to not get the notification anymore.

    • Osku says:

      June 21, 2017

      Same thing keeps happening for me. It does not install the update.

Subscribe

Subscribe for updates