PyCharm 2018.3.1

PyCharm 2018.3.1 is now available, with various bug fixes. To update, choose Help | Check for Updates in the IDE, or download it from our website.

Improved in This Version

  • A fix for the recently added WSL support in PyCharm 2018.3
  • An issue where PyCharm couldn’t correctly authenticate over SSH using a passphrase-protected private key has been resolved
  • A few fixes for Docker and Docker Compose
  • Fixes for the embedded terminal
  • Many fixes coming from WebStorm, DataGrip and IntelliJ IDEA; see the release notes for details

Interested?

Get PyCharm now on our website

If you’re on Ubuntu 16.04 or later, you can use snap to keep your PyCharm up to date. You can find the installation instructions on our website. Snap also works for various other Linux distros.

On Windows, macOS, and Linux, you can use our useful Toolbox App to keep all of your JetBrains IDEs up to date. Read more about the app on our website

This entry was posted in Release Announcements and tagged . Bookmark the permalink.

2 Responses to PyCharm 2018.3.1

  1. Trevor Loveland says:

    Cannot apply this update.
    I get a message that it does not have write access to /usr/share/pycharm.
    So I tried :
    sudo updatedb && sudo locate pycharm.sh
    sudo /path/to/pycharm.sht
    but I get end up with a conflicts error and requested to select solution from the column – virtually every row only allows me the option to “IGNORE” or “REPLACE”
    After restart get the same message that there is an update available.

  2. Jeremy K says:

    Yea I need help too. When I run ./bin/pycharm.sh, it gives me this.
    (java:14223): Gtk-WARNING **: 00:57:11.393: Unable to locate theme engine in module_path: “murrine”,
    It runs pycharm3 but doesn’t replace 2.

Leave a Reply

Your email address will not be published. Required fields are marked *