Welcome Ruby Plugin for IntelliJ IDEA 11.1

Posted on by Tatiana Vasilyeva

Hello everyone,

We’ve received a lot of positive and inspiring feedback since RubyMine 4 was released. We’re very glad and thankful to you for helping us go on in making RubyMine even better. And we know that some of you are working with Java and Ruby or JRuby at once and looking forward for all the new features to appear in Ruby plugin too.

So we are happy to let you know that Ruby plugin for the latest IntelliJ IDEA is out. It covers all the features that RubyMine 4 has. As usual you can install it from IntelliJ IDEA plugin manager.

Read about the new features on our site.


Develop with pleasure!
JetBrains RubyMine Team

Comments below can no longer be edited.

10 Responses to Welcome Ruby Plugin for IntelliJ IDEA 11.1

  1. Oliver says:

    March 8, 2012

    How to get it to work with the 11.1 IntelliJ EAP ? Even after installing 4.0.2.20120229 I still get “incompatible” in the plugin installer ?

    Any advice appreciated.

    • Dennis Ushakov says:

      March 8, 2012

      Current version of Ruby plugin is really not compatible with the latest EAP (116.32). We’re working on a compatible version right now, you can watch RUBY-10647

  2. Miguel madero says:

    March 22, 2012

    Are there any plans to do something similar for vs/Resharper. I know ironruby has taken off as jury, but there’s a lot of ppl working on .net and ruby.

  3. Yu Thang says:

    April 4, 2012

    Still incompatible with Idea 11.1.1 (build 117.117), avoid upgrading if you use Ruby plugin.

  4. Rupesh says:

    April 10, 2012

    Hi Yu,

    When can we expect the latest ruby plugin to be compatible with Idea 11.1.1 (build 117.117)?

    Thanks
    Rupesh

    • Dennis Ushakov says:

      April 10, 2012

      Ruby plugin was updated at Friday and is compatible with 117.117. You can check for updates manually. Please report if it still doesn’t work for you

  5. Roberto Garcia says:

    July 28, 2012

    Trying to use Ruby plugin (4.5.0.20120718) but incompatible with IntelliJ 11.1.3 (build 117.798)

    • Tatiana Vasilyeva says:

      July 31, 2012

      The last Ruby plugin is compatible with the last EAP versions of IDEA only (since build 120.156). For IntelliJ 11.1.3 please use 4.0.3.20120406.

  6. Mike Greco says:

    September 12, 2012

    Can someone please explain what the incompatibility is between Ruby plugin (4.5.0.20120718) and IntelliJ 11.1.3 (build 117.798) ?

    Is there any time frame for when Ruby plugin (4.5.0.20120718) will be compatible with IntelliJ 11.1.3 (build 117.798) ?

    Thank You !

  7. Yusup says:

    October 26, 2012

    we cant use 4.0.3 plugin on intellij idea 11, cant download from plugin manager or website
    .hope you fix this soon

Subscribe

Subscribe for updates