PhpStorm & WebStorm 2.0 Early Access Program started

Alexey Gopachenko

We’re happy to announce first public builds of PhpStorm & WebStorm 2.0

While our roadmap is pretty extensive, in first EAP build you’ll get:

  • PHP refactorings: Smart introduce field / constant, inline variable
  • PHP inspections: Control flow / Unreachable statement & Wrong catch clauses order, Probable bug / Wrong string concatenation operator, Type compatibility / Invalid foreach() argument type
  • PHP structure view window was reworked and now offers various sorting and filtering options
  • Streamlined UI of IntellJ platform version X. You’ll notice compact scrollbars with overlayed inspector info, more native UI on Mac OS X. Windows and Linux users still may want to go to Settings | Look and Feel and selectWindows/GTK+
  • Git support with built-in history views, cherrypicking and easy branch switching
  • Injected language fragments editor. Note that is will not work with PHP concatenated string expressions yet
  • RELAX NG support with code inspection
  • Lots of bugfixes and improvements in all subsystems, check project issue tracker for complete changelog.

Please note that ALL of this is work in progress and will undergo series of both technical and cosmetic changes during next months.

Download PhpStorm & WebStorm 2.0 EAP build 96.1009 for your platform from project EAP page.

Develop with pleasure!
-JetBrains Web IDE Team

P.S. You’ve only several days left before 50% discount special offer will end.

Comments below can no longer be edited.

12 Responses to PhpStorm & WebStorm 2.0 Early Access Program started

  1. raveren says:

    August 24, 2010

    the php storm windows link is broken
    http://download-ln.jetbrains.com/webide/PhpStorm-96.1009.exe

  2. Alexey Gopachenko says:

    August 24, 2010

    Looks like PhpStorm Win exe is still uploading to CDN. You’ve got to wait a bit…

  3. markan says:

    August 24, 2010

    The PhpStorm exe download still won’t complete for me (it gets to about 98%) and I’ve tried 3 different browsers in case. It might be worth checking it.

  4. Urkman says:

    August 24, 2010

    Hello,

    thanks for your great work 🙂
    Waiting for the ZendDebugger Support…

    Greetings,
    Urkman

  5. Kamil T. says:

    August 24, 2010

    Hey, just one question – if we’ll buy a personal license for WebStorm now, for 1.0, then are we eligible for upgrade to 2.0 free of cost?

  6. Eugene says:

    August 24, 2010

    Not found mercurial support in the build. When are you planning to add that? This is very important functionality for us.

  7. Eugene Toporov says:

    August 25, 2010

    @markan: downloads fine for me

    @Kamil T.: you are eligible to ALL updates released during the year since your purchase. After one year, you can continue using the IDE, but to get a new update you’ll need to renew your license.

    @Eugene: Mercurial support it coming. Watch EAP announcements for notification.

  8. Antoine says:

    August 25, 2010

    I have bought a license for phpstorm but the fact that namespace support is TERRIBLE i have to use netbeans instead. This should have an extremely high priority in my opinion since all framework are moving to namespaced version

  9. Kamil T. says:

    August 25, 2010

    Ah, of course. BTW, what does Sass or LESS support means? You will support just syntax or also build process?

  10. Alexey Gopachenko says:

    August 26, 2010

    @Antoine Full namespace support will be ready to 2.0 release.

  11. Alexey Gopachenko says:

    August 26, 2010

    @Kamil T. Well, both SASS and LESS syntax is support is ready, so the “compilation”/build process is only outstanding issue. We do not have it scheduled though yet. Watch http://youtrack.jetbrains.net/issue/WI-2900

  12. Daniel says:

    August 26, 2010

    Hi guys,

    i still waiting for LESS and Zend support. I’v already bought a licence because i love this cool IDE and all the amazing features!

    Cheers,
    Daniel