PhpStorm & WebStorm 5.0.4 released

Never say never: a couple of very annoying regressions somehow sneaked into v5.0.3. Thus we’re releasing 5.0.4 today, focused solely on getting rid of these and polishing v5.0 before we dive into v6 experimental builds.

Download PhpStorm & WebStorm 5.0.4.
Automatic update is available from 5.0.3 release build.

Develop with pleasure!
– JetBrains Web IDE Team

This entry was posted in PhpStorm, Release Announcements, WebStorm and tagged , , . Bookmark the permalink.
  • Colin Mollenhour

    Thanks, Jetbrains team! Your ability to release new features so frequently and still end up with a truly stable build occasionally is fantastic!

  • Gregor Panek

    Thanks for this update! A link to the change release log would be also helpful in this blog post :)

  • Kris
  • zoka

    Hey guys!

    There is an annoying SVN thing I click save credentials checkbox but it asks me for SVN password every time I start application again.

    Anyway congratulations for amazing IDE. After Zend Studio 5 I was without IDE you saved me.

  • levon

    Thank you for fast development. #1

  • aragnophy

    Thanks for new build, but again “Save credentials” broken (at least for SVN). The same issue was in 5.0.2 and fixed in 5.0.3… Really annoying…

  • Sebastiaan Stok

    Ah the JSLint errors are fixed.

  • Nadav

    What have been changed? Can you provide us with a changelog? Or can someone tell what have been fixed/changed/added?

  • Chris R

    @SVN bugs, please post details on this bug report…

    Hopefully it’ll help get this issue fixed.

  • Kris

    I have seen a bug in PHPstorm 5.3 . I have seen update now not sure if this has been solved ( I have not reported yet on yourtrack)

    Today when I run phpstorm it’s not run. I restart it. Close it from task manager and make many restart but it’s not worked. I restart my system not solve it yet.

    After some min without playing with it I restart it and it’s work then. Can someone help me how this happen.
    it’s not solved even I delete .webide in document folder.

    • Andriy Bazanov

      First time I hear about PhpStorm v5.3 — maybe 5.0.3 instead?

      In any case — please check your idea.log (Help | Reveal Log in …) and post details in the forum if required.

    • Yehosef
  • Robin Monks

    I find most phar files I use /still/ don’t open properly on this release. Example:

    Which is rather annoying.

    • Andriy Bazanov

      Works fine for me — I can see phar structure and open any file (read-only, of course) — checked about 20 files.

      Can you please tell what exactly does not work (use forum for details)?

      • Robin Monks

        Seems that it has to do with phar files being inside another project, vs being the project themselves.

        • Andriy Bazanov

          I’m not using phar files myself that much (but it is part of the project) and cannot understand the issue here. If you think there is a bug here then please file new ticket to the Issue Tracker

  • B-rad

    For a while now, it continues to remind me that it will install the Chrome extension the next time Chrome restarts. The extension already shows up in Chrome but never seems to do anything (note: I’ve never really tried to use any of its features).

    • Andriy Bazanov

      This extension is for JavaScript debugging as well as LiveEdit functionality (possibly some other as well)

  • Tyson Phalp

    I’m on 5.0.2, and I’m getting the notification for 5.0.4, but it doesn’t offer to upgrade. The upgrade notification dialog only has buttons for, “Release Notes”, “Remind Me Later”, and “Ignore This Update”.

    I downloaded the release manually, but when it begins the install, it wants to put it in a different directory, not where the current version is installed.

    Any ideas? Thanks.

    • Andriy Bazanov

      Patch (upgrade from within IDE) is only available for consecutive releases (5.0.1 -> 5.0.2 -> 5.0.3 -> 5.0.4). Therefore it cannot be used to upgrade 5.0.2 to 5.0.4.

      You have to use full manual install and it has to be installed into an empty folder. Two choices here (I’m assuming you are on Windows):
      1) Install into the folder offered by installer (will be PhpStorm 5.0.4). You can uninstall older version later (or in advance).
      2) Install into the same folder — uninstall previous version first; go to that folder and remove all outstanding files and folders (there should be 1-2 folders left with 2-3 small files); install new version into that (now empty) folder.

  • Bryan Green

    A good IDE makes all the difference. PHPStorm saves me time and the integration of SCSS, Javascript and PHP is zen!
    I’d like to try your other environments in the future (IntelliJ IDEA or .NET Resharper add-on.)

  • shujat

    how can i get a key