Ending Support for RubyMotion and Heroku Integration Plugins

Dear all,

We plan to discontinue support for the following plugins in RubyMine v2019.3:

Unfortunately, these plugins have gained very little traction and are seldom used, coupled with the impractical maintenance they need, we feel that our efforts would be best spent elsewhere.

The end of support means that these plugins will be incompatible with v2019.3 and newer, and they will no longer be updated. Therefore, new feature requests and bug reports will also not be accepted.

We are publishing the source code for the RubyMotion support plugin in case you want to customize it for your own needs or contribute to it and support it for the community: https://plugins.jetbrains.com/plugin/10674-rubymotion-support.


UPD: You can find source code for the RubyMotion and Heroku plugins in the ‘intellij-obsolete-plugins’ repository:

We are sorry for any inconvenience caused.

Should you have any questions, please feel free to ask them in the comments section below.

Cheers,
Your RubyMine team

This entry was posted in Announcement and tagged , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *