PhpStorm & WebStorm 4.0 Beta (EAP 117.132)

Alexey Gopachenko

The time frame for new features in 4.0 is closed and todays EAP is a Beta – we will focus on performance and bugs from now on.

Please report all problems ASAP – and do not use twitter or blog comments, file them to tracker.

    More details on build changes available in build changelog and platform changelog

    Download PhpStorm & WebStorm for your platform from project EAP page.
    Patch-update is also available.

    Develop with pleasure!
    -JetBrains Web IDE Team

    Comments below can no longer be edited.

    12 Responses to PhpStorm & WebStorm 4.0 Beta (EAP 117.132)

    1. Alexey Gopachenko says:

      April 4, 2012

      Please wait a hour for CDN to settle down and downloads will become available for everybody.

    2. Sam says:

      April 4, 2012

      Hello,

      is there a chance that jetbrains is going to release 4.0 till 08.April?
      What is the plan?

      Sam

      • Alexey Gopachenko says:

        April 4, 2012

        We usually do not disclose exact release dates. I can only tell its SOON.
        Why are you asking? 🙂

        • Sam says:

          April 4, 2012

          hmmm,

          you got me 😉

          i’m asking because till this date i’m entitled to a free update 😉

          • Alexey Gopachenko says:

            April 4, 2012

            Well, 08.April is like what – 4 days from today’s beta? Not THAT soon, sorry.

    3. Vladislav says:

      April 4, 2012

      still no symfony support even in 4.0?

      • Alexey Gopachenko says:

        April 4, 2012

        Nope, and was not planned. Just as other frameworks.

    4. Vladimir says:

      April 4, 2012

      So no Symphony nor any other framework. And for future versions only Zend and Symphony FW support. Sorry to say, but no more subscriptions from me when this one ends in July.

      • Alexey Gopachenko says:

        April 4, 2012

        Well, roadmap is not complete, yet, indeed, all framework-specific features are definitely not the top priority. Too much basic stuff to improve. And THEN it will be easier to add framework features.

        • Bryan Green says:

          April 4, 2012

          I agree. Nail the basics first.

    5. koubel says:

      April 4, 2012

      4.0 has different – WI-10547, WI-10323 – and buggy WI-10489 phpdoc inspection and completion compared to 3.0.

      I think all above mentioned issues can be classified as regressions and bugs, most of these has no fixed version set, although were reported for previous 4.0 EAP.

    6. koubel says:

      April 4, 2012

      also consider WI-10482 – required phpdoc @throws everywhere