IntelliJ IDEA 14 EAP 139.1 available, from a release branch already

Posted on by Eugene Toporov

A fresh update to IntelliJ IDEA 14 EAP is released and you may note we’ve switched to a “release” branch (139) already, so the release is not far away already and we’re in a “stabilization phase” mostly.

We urge you to check the full release notes to compare this build to the previous one.

A number of not so big but important features for everyone was added recently to the editor, including “Go to Next Edit” command, which is the opposite to a very useful “Go to Last Edit”, an additional options to show white-spaces only in front and/or behind and a number of other changes.

We need your feedback now even more than before. It is very welcome in our discussion forum or directly in the issue tracker.

Develop with Pleasure!

Comments below can no longer be edited.

13 Responses to IntelliJ IDEA 14 EAP 139.1 available, from a release branch already

  1. Stephan says:

    October 9, 2014

    Great news! But unfortunately, AngularJS support is broken in the current EAP ๐Ÿ™

    Regards,
    Stephan

    • Ekaterina Prigara says:

      October 10, 2014

      Thanks for the report, we’ll fix that asap.

  2. Patrik says:

    October 10, 2014

    NodeJS is broken also. Can not test this version at the moment ๐Ÿ™

    • Ekaterina Prigara says:

      October 10, 2014

      Sorry for that, we’ll fix that asap.

  3. Bill C. says:

    October 10, 2014

    Why is the OS X version bundled with JRE7 while the Windows version is bundled with JRE8? Did you have an issue with JRE8 in OS X?
    I modified the plist to use JDK8 on my computer running OS X and haven’t seen anything yet.

    • Andrey Cheptsov says:

      October 14, 2014

      The default OS X bundle comes with JRE 1.6, other JRE versions still have a number of issues. However you can download the bundle with JRE 1.7, or modify your .plist file manually.

  4. Patrik says:

    October 10, 2014

    I love your IDE very much. Privately I have no money to buy it, but in company I’m working in, we have already ordered several PHPStorms and InteliJs. Let me know, if I can help you somehow on Beta testing! NodeJS is working again at the moment!

    • Eugene Toporov says:

      October 13, 2014

      Thank you very much Patrik! Your feedback on our EAP builds is just what we need. It’s highly valuable and we very much appreciate it.

  5. Rohit says:

    October 13, 2014

    EAP 139.1 keeps throwing a dialog every couple of minutes with message
    Could not save project: The Content already has an existing parent “project”

    Any workarounds/suggestions or the only option is to wait till a new build.

    Thanks
    Rohit

  6. Sebastian says:

    October 14, 2014

    I still have Version 12. Can I buy a upgrade from that version to version 14 after it’s released?

    I don’t want to buy an upgrade to Version 13 at the moment.

    • Andrey Cheptsov says:

      October 14, 2014

      If you upgrade to v13 (personal license) now you’re supposed to get 1-year upgrade subscription. Please check it at https://www.jetbrains.com/idea/buy/choose_edition.jsp?license=PERSONAL&#upgradeuser

    • Eugene Toporov says:

      October 14, 2014

      Sebastian,
      Generally, yes, you can upgrade to v.14 once it is out, skipping v.13.
      Or, as Andrey mentioned, if you upgrade now, you’ll get v.13, v.14 and all versions that we release during one year.

Subscribe

Subscribe for updates