PhpStorm & WebStorm 2.1.2 released!

We are pleased to announce the immediate availability of PhpStorm 2.1.2 & WebStorm 2.1.2 bug fix update. It contains important fixes and significant performance improvements in JavaScript, PHP and CSS support and is strongly recommended update for all users.

Do not hesitate! Download WebStorm 2.1.2PhpStorm 2.1.2 Automatic patches from 2.1.1 release are also available.

We’d also like to encourage all users to send anonymous feature usage statistics that was recently introduced to our IDE. This helps us to focus on most important stuff. Enable at Settings|Usage Statistics

Develop with Pleasure!
-JetBrains Web IDE Team

This entry was posted in PhpStorm, Release Announcements, WebStorm and tagged , , . Bookmark the permalink.
  • Marek Polášek

    Autoupdate from PhpStorm 2.1.2 (107.403) to 2.1.2 (107.425) does not work :( Is here different solution than uninstall my PhpStorm build, downlod and install new one?

  • SecondFrog

    Syntax highlighting bug still not fixed. I wrote about it in previous topics twice. It’s sad.

  • Alexey Gopachenko

    @SecondFrog Bug reports should go to project issue tracker where we can discuss problem, request additional information and you’ll be able to watch the progress.

  • dec5e

    On PHPStorm Download page is still link to 107.403 release

  • harvi

    I downloaded the Linux version, but there are not build#107.425. It still #107.403.

  • Alex

    @harvi: had the same problem and solved it by adding some random stuff eg ?abcd after download url to prevent caching

  • SecondFrog

    @harvi: i have the same problem on Windows.

  • SecondFrog

    Last-Modified: Thu, 14 Jul 2011 12:52:47 GMT

  • SecondFrog
  • harvi

    @Alex: I tried this solution – it didn’t solve the problem

  • Alexey Gopachenko

    Ok, sorry everybody, same-named downloads will take time to get in sync across CDN.

    We’ll work on providing new names and links, stay tuned.

  • Alex

    @harvi: i see, worked for me though, maybe i was lucky :)

  • Nils Luxton

    Opening a copy of 2.1.1 (rather than 2.1.2-RC) allowed me to do an in-place update using Help|Check for update…

    Might help someone out there :)

  • Alexey Gopachenko

    Yeah, patches from 2.1.1 are working as usual.

  • Karl

    Bunch of crybabies… :) SCNR. For me the update worked smoothly. Thx!

  • Keith Davis

    As I posted here, where did the .zip version download link go?

    http://devnet.jetbrains.net/message/5311877#5311877

  • Vladimir

    @Marek Polášek: try starting ide as Administrator, and then update, after restart you will see update dialog.

  • DEM

    Please fix highlighting SCSS code and autocomplete.
    See screenshot – http://clip2net.com/clip/m27950/1311158088-clip-38kb.png

  • Aicke Schulz

    I don’t know if that was fixed in this issue (I could not find an entry in the changelog), but our JIRA connection works again with the new version of PhpStorm. I thought it was a configuration problem with our server, but it was obviously broken in one of the earlier versions of PhpStorm.

  • Ваш “любимый” customer

    Надеюсь, следующий EAP будет, всё-таки, 3.0.