Start 2010 with RubyMine 2.0.1

Eugene Toporov

2.0.1 — first version in 2010. I like these small numbers and digits surprises!

But, to the point. We’ve just made RubyMine 2.0.1 available and hope you will enjoy it.

This is the minor update with some performance improvements, stability and other fixes. We’ve ensured that RubyMine works well with the latest Ruby on Rails (v.2.3.5) and Cucumber (v.0.5.x and later).

Among other fixes:

  • fixed plugin repository access from RubyMine UI (IDE Settings | Plugins)
  • fixed Extract Superclass refactoring
  • added support for ‘IDEA Server’ plugin that allows sharing IDE configuration between RubyMine installed on different computers

But we could not resist to make something new as well:

See complete list of fixes in RubyMine issue tracker and go download RubyMine 2.0.1.

Develop with pleasure in 2010 with RubyMine 2.0.1
-JetBrains RubyMine Team

Comments below can no longer be edited.

10 Responses to Start 2010 with RubyMine 2.0.1

  1. Husein says:

    January 19, 2010

    It’s not uploaded yet? I get 404 error while trying to download it.

  2. Eugene Toporov says:

    January 19, 2010

    Hi Husein,
    All files are there. Just tried and works fine.
    Thanks.

  3. Husein says:

    January 19, 2010

    Works fine now. Thanks!

  4. Stefan says:

    January 20, 2010

    Hey guys. Just wanted to let you know that you are awesome and great and everything.

  5. John says:

    January 20, 2010

    Guys, thanks. Now could you please fix the bug tracker? I’ve been trying to report a bug for the past week, but the bug tracker gives me:

    504 Gateway Time-out

    nginx/0.7.64

    The bug I’m reporting? Paste on OS X is broken…it’s killing me to not have it.

    Thanks.

  6. Eugene Toporov says:

    January 21, 2010

    @stefan: Thanks Stefan!

    @John: Tracker dev team is working hard on the stability. A fresh EAP build was rolled our recently and it brought up some of its problems. Thanks for your patience.
    Please check this issue for copy/paste — http://youtrack.jetbrains.net/issue/RUBY-5040
    Also, you are welcome to post details to our discussion forum at http://www.jetbrains.net/devnet/community/ruby
    Cheers!

  7. John says:

    February 2, 2010

    @Eugene, I’m shocked that you’d test an alpha of a bug tracker when you have *paying* customers like me relying on said bug tracker to report our issues. FYI, it’s still not working. I still can’t reliably get in. Still the nginx bad gateway problem.

    Also, I’ve signed up to the forums with three different logins, and each of them still say my password is incorrect. Even after resetting it. Again. and Again. and Again.

    This is perhaps the most frustrating experience I’ve had with paid software since I stopped using Microsoft products. Please help!

  8. Jamal Abdou-Karim Bengeloun says:

    February 10, 2010

    What about rails 3.0 support?

  9. yury says:

    February 10, 2010

    Please update bundler support

  10. Eugene Toporov says:

    February 11, 2010

    @Jamal: Check this about Rails 3 support: http://www.jetbrains.net/devnet/thread/286654

    @yury: updated Bundler support will be available in the nearest RubyMine 2.0.2 update. Stay tuned!

Subscribe

Subscribe for updates