Kotlin logo

The Kotlin Blog

Kotlin Programming Language by JetBrains

Kotlin 1.5.0-M2 发布了——确保平滑迁移至 Kotlin 1.5.0

Kotlin 1.5.0-M2 是 Kotlin 1.5.0 在这个春天的最后一个里程碑版本。 因此,这是确保您的项目能与 Kotlin 1.5.0 成功合用的最后时机。

安装 1.5.0-M2

如果现在就迁移您的项目,那么可以节省您未来(Kotlin 1.5.0 推出时)的时间和精力,还可以帮助我们在正式发布前提供紧急修复。

例如,如果您试用在 1.5.0 中成为默认的 新的 JVM IR 后端并且现在发现了任何问题,我们都会努力在正式发布前提供修复。 您可以向我们的问题跟踪器(YouTrack)报告所遇到的任何问题。

请注意,Jetpack Compose 只适用于新的 JVM IR 后端。 因此,如果您试用过 Jetpack Compose,那么您已经在用新版后端了。

乐享预览版的简化配置

往,如果您决定在现有项目中使用预览版,那么必须在 Gradle 文件中指定额外的 Bintray 存储库。 现在,所有 Kotlin 预览版构件都存储在 Maven Central,并且无需手动添加存储库

省时省力! 如需使用 M2 版本,将项目中的 Kotlin 版本号改为 1.5.0-M2,并在必要时调整库依赖即可。

安装 1.5.0-M2

分享您使用新语言特性的真实案例

您是否有已经有机会来测试 Kotlin 1.4.30 中的实验性语言特性?

如果还没有,不妨现在一试! 如果您已经在用了或者刚刚实验过,那么可以为我们提供一个好的用例。 😉 这是个不用保守的秘密, 分享给我们吧!

我们的文档团队经常会收到这样的反馈 🗣:

"Please add more samples to documentation".

"It’s not clear without real-world examples".

"Could you provide samples with detailed explanations?"

请帮助我们在语言文档中提供更多真实示例,让其有助于像您一样的开发人员。

分享语言特性样例

别错过 Kotlin 1.5.0 相关视频

Kotlin YouTube 频道 可供喜欢看视频的人使用。 我们正在不断向频道更新视频,并且计划发布一个致力于 Kotlin 1.5.0 的视频专辑。即刻抢先观看吧🎥!

订阅 Kotlin YouTube


还没有使用 Kotlin 1.5.0 来验证您的项目吗? 不妨马上安装 1.5.0-M2 以避免以后遇到问题。

特别感谢由来自 Kotlin 社区的 Jia Yanwei (hltj) 为本篇博文提供中文译文。

Discover more