Dotnet logo

The .NET Tools Blog

Essential productivity kit for .NET developers

News

ReSharper and Rider 2021.2 will require .NET Framework 4.7.2 or newer installed on Windows

Starting with the 2021.2 releases of our .NET productivity tools, including ReSharper and Rider (on Windows), we will require .NET Framework 4.7.2 or newer installed on your machine. Earlier versions of our .NET tools will continue to work on .NET Framework 4.6.1.

Which products does this apply to?

This change applies to the upcoming 2021.2 versions (and newer) of ReSharper, ReSharper C++, Rider (on Windows), Rider for Unreal Engine, dotTrace, dotMemory, dotCover, and dotPeek.

This change also applies to the Windows versions of the ReSharper Command Line tools, like dupFinder, InspectCode, and CleanupCode.

Why is this changing?

Three years ago, we switched to targeting .NET Framework 4.6.1 for ReSharper and Rider (on Windows). We did so because of the .NET Standard 2.0 support, which lets us target both the full .NET framework on Windows, and .NET Core on other operating systems.

This allowed us to make the ReSharper Command Line tools and Rider work on Windows, macOS, and Linux. We found that there were some compatibility issues, and Microsoft also recommended targeting a newer framework version in one of the footnotes of the .NET Standard 2.0 documentation.

Newer versions of the .NET Framework also come with numerous improvements. There’s better performance, security, and Windows Presentation Foundation updates, such as per-monitor DPI support. The NuGet client SDK used by ReSharper and Rider also requires a more recent .NET Framework version.

By making use of the newer, modern runtime, we get to make use of these improvements in our .NET tools, which will benefit you and our other customers.

What does this mean for me?

For many of our customers, no action will be required. If you are using a newer version of Windows 10 or Windows Server 2019, or you have Visual Studio 2019 installed with the desktop development workload enabled, all prerequisites are there! .NET Framework 4.7.2 is already installed, and supports the 2021.2 and newer releases of ReSharper, ReSharper C++, Rider (on Windows), Rider for Unreal Engine, dotTrace, dotMemory, dotCover, and dotPeek.

On older operating systems, you may have to install .NET Framework 4.7.2. This is the case for Windows 7, 8.1, and Windows 10 prior to version 1803. On Windows Server, you will have to install .NET Framework 4.7.2 if you are on version 2008 R2 SP1, 2012, 2012 R2, 2016, or Windows Server version 1709.

If this change affects your current workflow, please get in touch!

Will I need to retarget my own projects as well?

No. The .NET Framework 4.7.2 runtime is only required to be able to run the 2021.2 and newer versions of ReSharper, ReSharper C++, Rider (on Windows), Rider for Unreal Engine, dotTrace, dotMemory, dotCover, and dotPeek.

In our productivity tools for .NET developers, we strive for compatibility with as many versions of the .NET Framework and Visual Studio as possible. Projects targeting .NET 3.5 or .NET 4.5, for example, will still be supported in our .NET tools, and continue to benefit from rich code editing and code generation features, code analysis and quick-fixes, powerful refactorings, excellent navigation, and more!

Discover more