PHP code insight in Upsource 3.5

Posted on by Maria Khalusova

In the recent release, Upsource 3.5, we have significantly improved PHP code intelligence features announced in the previous release. We’ve added support for composer dependency manager and made it possible to explicitly specify external dependencies. In Upsource 3.5 you can now set the PHP language level, and fully enjoy smart code review features.

In the following video Gary Hockin, a Developer Advocate for PhpStorm at JetBrains, explores Upsource and its PHP code insight. Check it out!

https://youtu.be/KaRhE3I9YCs

Comments below can no longer be edited.

5 Responses to PHP code insight in Upsource 3.5

  1. Bram says:

    November 15, 2016

    Every file now has the warning “Not in the contents root of any project”. Searched the web and the help pages, no mention of this warning. How to solve?

    • Raman Gupta says:

      March 8, 2017

      I’m having the same issue. Any luck solving it?

      • Valerie Andrianova says:

        March 9, 2017

        Hi Raman,
        We need more details to investigate the issue. Unfortunately, there is no general solution. Could you please create a support ticket:https://upsource-support.jetbrains.com/hc/en-us?
        Thanks,

  2. Isfett says:

    April 8, 2018

    Do you plan to add phpcs/phpmd in the future?

    • Leonid Khachaturov says:

      July 12, 2018

      There are no such plans so far.

Subscribe

Subscribe for updates