AppCode 2016.1 RC2 is out

Hi everyone,

After the first 2016.1 release candidate we decided to publish an update, which addresses the following important issues:

  • Issue with completion in for-in loop (OC-13343)
  • Performance regression in Swift code completion (OC-13339)

In addition in this build we decided to temporarily revert changes for DerivedData location (OC-13193) due to the multiple issues caused by this change.

Important note: this week Xcode 7.3 was released and as we wrote in AppCode 3.3.3 release post, AppCode 3.3.3 is not compatible with Xcode 7.3 due to some crucial changes in debugger which prevent AppCode from starting iOS application on the simulator while running/debugging. This issue was fixed in the first 3.4 EAP build and it means that this fix is already included into AppCode 2016.1 RC2, so we would like to ask everybody who updated Xcode to the 7.3 version to use the current RC build instead of AppCode 3.3.3.

As usual, you can download AppCode 2016.1 RC2 from our confluence page. Note, that this RC build requires an active AppCode license or is available for 30 day evaluation.

Feel free to share your feedback in the comments section below. In case you find any problem, please report it to our tracker.

banner
This entry was posted in Announcement and tagged , . Bookmark the permalink.

9 Responses to AppCode 2016.1 RC2 is out

  1. Fabian says:

    Is there a reason this is no more an EAP? RC1 still was an EAP version.

    • Stanislav Dombrovsky says:

      The reason is that it is RC. RC1 was made as en EAP due to some internal reasons, so it’s mostly an exception.

      • Fabian says:

        Ah ok. The switching between EAP and non-EAP sucks a little, as I need to adapt all the file references with every switch. Couldn’t we activate a “beta” channel for AppCode instead? Or always have an EAP, so while RC have an EAP with the same code state?

        • Maksim says:

          But where i can “As usual, you can download AppCode 2016.1 RC2 from our confluence page. Note, that this RC build requires an active AppCode license or is available for 30 day evaluation.” ? :)

  2. Maksim says:

    There is not download link on your confluence page

  3. zhangyang says:

    now my currentVersion is the newest AppCode 3.3.4,and my xcode is 7.3,but i canot use the appcode’s debug function!

Leave a Reply

Your email address will not be published. Required fields are marked *